Package Details: mingw-w64-qt5-base-angle 5.14.0-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-qt5-base-angle.git (read-only, click to copy)
Package Base: mingw-w64-qt5-base-angle
Description: A cross-platform application and UI framework (mingw-w64)
Upstream URL: https://www.qt.io/
Licenses: custom, GPL3, LGPL3, FDL
Groups: mingw-w64-qt5
Conflicts: mingw-w64-qt5-base, mingw-w64-qt5-base-angle, mingw-w64-qt5-base-dynamic, mingw-w64-qt5-base-noopengl, mingw-w64-qt5-base-openql
Provides: mingw-w64-qt5-base
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 15
Popularity: 0.000000
First Submitted: 2016-08-19 20:15
Last Updated: 2019-12-24 21:52

Required by (45)

Sources (32)

Pinned Comments

Martchus commented on 2016-05-18 22:01

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
Patches for this package are managed at: https://github.com/Martchus/qtbase/tree/5.7.0-mingw-w64

There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff

For general notes, discussion and issues not only concerning this variant please use the comment section of the package mingw-w64-qt5-base.

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 Next › Last »

ant32 commented on 2013-10-26 21:38

Run the sed command in the follwoing directories.
/usr/i686-w64-mingw32/lib/cmake/
/usr/x86_64-w64-mingw32/lib/cmake/

sed -e 's|\(set(imported_location "${_qt5Core_install_prefix}/bin/.*\)\(")\)|\1-qt5\2|g' \
-e 's|\(set(imported_location "${_qt5.*_install_prefix}/\)lib\(/${LIB_LOCATION}"\)|\1bin\2|g' \
-e 's|\("Qt5.*.dll" "\)\(Qt5.*.\)lib"|\1lib\2dll.a"|g' \
-e 's|\(Qt5.*.\)lib"|lib\1dll.a"|g' \
-e 's|/include/qt5//QtANGLE"|/include/qt5/QtOpenGL"|g' -i */*.cmake

If it works or doesn't work or if you know of a way to improve this please let me know.

ant32 commented on 2013-10-26 18:28

Sorry, I have a sed script that fixes the cmake. I meant to post it the other day but didn't get to it. I'll post it in a couple hours when I have access to my laptop again. Fedora also has a patch that I meant to take a look at but didn't get the time yet.

travnick commented on 2013-10-26 16:28

[CMake]
I solved problem with Qt*.dll by symlinking Qt*.dll from bin to lib

but there is lack of *.lib files ...


CMake Error at /usr/x86_64-w64-mingw32/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:15 (message):
The imported target "Qt5::Core" references the file

"/usr/x86_64-w64-mingw32/lib/Qt5Core.lib"

but this file does not exist.

jellysheep commented on 2013-09-25 15:26

Thank you very much! I forgot to say that I use your binary packages, but I don't think it makes a big difference.

ant32 commented on 2013-09-25 15:16

@jellysheep I'll try finding time once I reach work in an hour

jellysheep commented on 2013-09-25 15:04

Hi,
when I try to build a package using mingw-w64-qt5-base with CMake, I get the following error:

<error>
CMake Error at /usr/x86_64-w64-mingw32/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:15 (message):
The imported target "Qt5::Core" references the file

"/usr/x86_64-w64-mingw32/lib/Qt5Core.dll"

but this file does not exist. Possible reasons include:

* The file was deleted, renamed, or moved to another location.

* An install or uninstall procedure did not complete successfully.

* The installation package was faulty and contained

"/usr/x86_64-w64-mingw32/lib/cmake/Qt5Core/Qt5CoreConfig.cmake"

but not all the files it references.

Call Stack (most recent call first):
/usr/x86_64-w64-mingw32/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:32 (_qt5_Core_check_file_exists)
/usr/x86_64-w64-mingw32/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:126 (_populate_Core_target_properties)
CMakeLists.txt:35 (find_package)


-- Configuring incomplete, errors occurred!
</error>

Symlinking /usr/x86_64-w64-mingw32/bin/Qt5Core.dll to /usr/x86_64-w64-mingw32/lib/Qt5Core.dll works, but then there are other files missing as well, and an include file "QtANGLE" is missing completely. Could you help me finding the error please?

ant32 commented on 2013-09-14 00:20

These now should compile fine against newer headers. I teasted them against r6277.
download binaries http://arch.linuxx.org

ant32 commented on 2013-09-13 02:44

Could someone please test these and tell me if they work and look good?
These now should compile fine against newer headers. I teasted them against r6277.
src tarball http://db.tt/WFzkkNqb
package http://db.tt/rfw6Zxvx
also take a look at https://aur.archlinux.org/packages/mingw-w64-qt5-base-static

ant32 commented on 2013-09-07 21:53

Will post a new PKGBUILD with the following two patches soon
https://codereview.qt-project.org/#change,64330
https://codereview.qt-project.org/#change,63747

ant32 commented on 2013-09-01 20:00

Someone just broght to my attetion that the exe files produced are 10 times larger then normal. For now just manually strip them using i686-w64-mingw32-strip program.exe or x86_64-w64-mingw32-strip program.exe. If some one finds a way to fix the PKGBUILD please leave a comment or email me. I'll look more into this tomorrow.