Package Details: mingw-w64-qt5-base-angle 5.14.1-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-qt5-base-angle.git (read-only, click to copy)
Package Base: mingw-w64-qt5-base-angle
Description: A cross-platform application and UI framework (mingw-w64)
Upstream URL: https://www.qt.io/
Licenses: custom, GPL3, LGPL3, FDL
Groups: mingw-w64-qt5
Conflicts: mingw-w64-qt5-base, mingw-w64-qt5-base-angle, mingw-w64-qt5-base-dynamic, mingw-w64-qt5-base-noopengl, mingw-w64-qt5-base-openql
Provides: mingw-w64-qt5-base
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 15
Popularity: 0.000000
First Submitted: 2016-08-19 20:15
Last Updated: 2020-01-30 10:20

Required by (45)

Sources (32)

Pinned Comments

Martchus commented on 2016-05-18 22:01

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
Patches for this package are managed at: https://github.com/Martchus/qtbase/tree/5.7.0-mingw-w64

There also exist a binary repository: https://martchus.no-ip.biz/repo/arch/ownstuff

For general notes, discussion and issues not only concerning this variant please use the comment section of the package mingw-w64-qt5-base.

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 Next › Last »

ant32 commented on 2013-08-30 16:06

Currently this and mingw-w64-qt5-base-static has to be built with mingw-w64-gcc-qt5 and mingw-w64-headers-secure (all other mingw-w64-qt5 packages built fine with the latest svn headers and with rubenvb's gcc). There is/was a build error with mingw headers newer then 5969 (PKGBUILD that builds headers r5969 https://gist.github.com/ant32/6295855. Changes to rebenvb's PKGBUILD https://gist.github.com/ant32/6295855/revisions). I want to see if I can make a deal that I or rubenvb will test mingw-w64-{headers,crt,winpthreads}-svn weekly and only update if the build is fairly successful.

ant32 commented on 2013-08-30 15:54

updated to 5.1.1
binaries can be found at http://arch.linuxx.org
I'm maintaining this package till brcha has time again.

ant32 commented on 2013-08-16 00:13

mingw-w64-qt5-serialport src http://db.tt/OMAgVeoY binary http://db.tt/Vq8tzHXT
mingw-w64-qt5-quickcontrols src http://db.tt/2bHid1om binary http://db.tt/DQ6vAPgm
mingw-w64-qt5-graphicaleffects src http://db.tt/X9Wa8uwH binary http://db.tt/jpvGqBlG

ant32 commented on 2013-08-15 03:48

I have created a Qt 5.1.0 src tarball http://db.tt/P0nPoVAv. I have not tested other then that it seemed to compile fine. Here is the link to the compiled package http://db.tt/LkuQjku3. Download other compiled mingw-w64 packages at http://arch.linuxx.org.

ant32 commented on 2013-08-14 02:15

I have created a Qt 5.1.0 src tarball http://db.tt/IdT24o8B. I have not tested other then that it seemed to compile fine. Here is the link to the compiled package http://db.tt/eYs5VJwW. Download other compiled mingw-w64 packages at http://arch.linuxx.org.

Anonymous comment on 2013-06-28 13:30

Hello brcha,

First of all, great thanks for these mingw-w64-qt5* packages. It helps a lot and save me an enormeous time !

I was wondering if you already tried to prepare mingw-w64-qt5-qtwebkit and mingw-w64-qt5-qtsvg packages ?

Thanks a lot, brcha :).

panda-z commented on 2013-06-17 14:24

It works! Thank you, ant32.

ant32 commented on 2013-06-17 14:02

You need to to have mingw-w64-gcc-qt5 installed to compile. Here is the link if you don't want to compile it yourself http://arch.linuxx.org/archlinux/AMR/os/x86_64/mingw-w64-gcc-qt5-4.8.1-1-x86_64.pkg.tar.xz
edit: the bug you mentioned is addressed in mingw-w64-gcc-qt5 package.

ant32 commented on 2013-06-17 12:37

You need to to have mingw-w64-gcc-qt5 installed to compile. Here is the link if you don't want to compile it yourself http://arch.linuxx.org/archlinux/AMR/os/x86_64/mingw-w64-gcc-qt5-4.8.1-1-x86_64.pkg.tar.xz

panda-z commented on 2013-06-17 07:13

I'm getting this error when compiling:
http://pastebin.com/H0bgHqfH

I think this is a regression bug in mingw-w64-gcc:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56038

Any suggestion?