Package Details: mingw-w64-pixman 0.38.4-6

Git Clone URL: https://aur.archlinux.org/mingw-w64-pixman.git (read-only, click to copy)
Package Base: mingw-w64-pixman
Description: The pixel-manipulation library for X and cairo (mingw-w64)
Upstream URL: http://xorg.freedesktop.org
Keywords: freedesktop mingw mingw-w64 pixman
Licenses: custom
Submitter: Schala
Maintainer: drakkan
Last Packager: drakkan
Votes: 14
Popularity: 0.63
First Submitted: 2012-08-13 05:22
Last Updated: 2019-09-10 05:16

Latest Comments

1 2 Next › Last »

drakkan commented on 2019-09-27 13:24

@pingplug, are you using mingw-w64-meson-1-11? It seems you don't have this commit:

279a8d0cdcf7

pingplug commented on 2019-09-27 13:09

ERROR: Got argument strip as both -Dstrip and --strip. Pick one.

jpcima commented on 2019-09-10 11:43

@drakkan I confirm, it is working correctly. Thank you.

drakkan commented on 2019-09-10 05:17

@jpcima, the meson build should be really fixed now

drakkan commented on 2019-09-08 22:54

oh yes, I was unable to fix this issue, so I switched back to autotools for now

jpcima commented on 2019-09-08 17:57

It's undefined (U). These should be T.

Are you sure eg. pixman-ssse3.c and others are linked under the meson build variant?

I see it listed in Makefile.am, but in pixman/meson.build I don't.

drakkan commented on 2019-09-08 16:30

While building I see these logs:

Checking if "MMX Intrinsic Support" compiles: YES 
Checking if "SSE2 Intrinsic Support" compiles: YES 
Checking if "SSSE3 Intrinsic Support" compiles: YES 
Checking if "GNU Inline ASM support." compiles: YES 
Run-time dependency OpenMP found: YES 4.5

Can you please check on your system? thanks

jpcima commented on 2019-09-08 13:15

Thanks for your work. My cairo build which is based on a configure-based pixman of the same version, has now trouble of a different kind.

I have undefined definitions refering to vector definitions of pixman implementation:

_pixman_implementation_create_mmx _pixman_implementation_create_sse2 _pixman_implementation_create_ssse3

Did this new build lose the CPU-specific optimizations? very unfortunate if the case, because I would like having these in my rendering.

drakkan commented on 2019-09-08 03:19

@jpcima, please update to mingw-w64-meson to 1-11 and retry using mingw-w64-pixman 0.38.4-4, it should work now, sorry for the annoyance

jpcima commented on 2019-09-07 20:54

Thanks @drakkan. Now the static library is present, but it is disfunctional. Compared to the configure-based build, the new file libpixman-1.a said "no symbols".

On the working build, I would be able to extract some symbol names off the library.

i686-w64-mingw32-nm /usr/i686-w64-mingw32/lib/libpixman-1.a | grep pixman_image_unref

00000260 T _pixman_image_unref