Package Details: mingw-w64-libpng 1.6.37-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-libpng.git (read-only)
Package Base: mingw-w64-libpng
Description: A collection of routines used to create PNG format graphics (mingw-w64)
Upstream URL: http://www.libpng.org/pub/png/libpng.html
Licenses: custom
Submitter: ekpyron
Maintainer: xantares
Last Packager: xantares
Votes: 23
Popularity: 0.71
First Submitted: 2012-03-22 22:58
Last Updated: 2019-10-23 17:19

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

ekpyron commented on 2014-11-14 11:27

@xantares

What makes you say that the flags you're setting in your mingw-w64-configure script are the "right compilation flags"? I see no reason why it would be "right" to use those...

xantares commented on 2014-11-14 10:56

hi,
would you mind using the mingw-w64-configure script ?
it would set the right compilation flags, thanks.
xan.

stativ commented on 2014-06-03 10:30

mingw-w64-libpng-static merged to mingw-w64-libpng

Schala commented on 2013-11-02 05:57

mingw-w64-libpng already has a static lib in addition to a DLL import lib

ant32 commented on 2013-10-28 23:39

!libtool isn't needed anymore since it is the default now. https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/pacman&id=81e5580e5f69a2c2dd5f0a347e66bd6bce5c4b3f

ekpyron commented on 2013-10-07 13:11

@xantares
Thank you, I added !libtool to options, so they should be gone now.

xantares commented on 2013-10-07 12:36

Hi,
There are useless libtool (.la) files in arch/lib
x.

Schala commented on 2013-07-23 21:27

Well I suppose having wine is a temporary workaround.

ekpyron commented on 2013-07-23 21:15

@Schala, yes I know, but as I modified the package, the flag was unset again. I didn't update to 1.6.3 earlier, because libpng had not yet been updated in [core].

I now updated the package, but I'm experiencing a (mild) problem with it: it seems to try and execute some target executable (wine is started in my case) while building. As so far it doesn't look like this is actually interfering with the build, I still update the package, but I don't have the time to have a detailed look at this right now. I'd appreciate any comments.

Schala commented on 2013-07-23 20:48

It's not that the download link isn't working. I flagged it because 1.6.3 is out