Package Details: mingw-w64-clang-git r94.7eee3ab-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-clang-git.git (read-only, click to copy)
Package Base: mingw-w64-clang-git
Description: MinGW clang wrapper (wclang)
Upstream URL: https://github.com/tpoechtrager/wclang
Licenses: GPL
Conflicts: mingw-w64-clang
Provides: mingw-w64-clang
Submitter: xantares
Maintainer: xantares
Last Packager: xantares
Votes: 6
Popularity: 0.000000
First Submitted: 2018-12-28 15:01
Last Updated: 2018-12-28 15:01

Latest Comments

1 2 Next › Last »

patlefort commented on 2021-11-05 10:23

@dsbabkov I managed to build openmp and provided a package mingw-w64-openmp. Try it out and tell me if it work fine.

dsbabkov commented on 2021-09-24 12:26

Unfortunately, I have no enough skills to do that. While building openmp from source (got it here: https://releases.llvm.org/download.html) there is fail on call ml/ml64. Tried to replace compiler by JWasm and uasm - did not work out... Seems I have to make some patch to workaround this problem

xantares commented on 2021-09-24 11:15

hi @dsbakov, I dont know, you're free to try to rebuild openmp to see if that works though

dsbabkov commented on 2021-09-24 09:31

Thank you for the package! How can i use it with OpenMP? I'm getting cmake error: Could NOT find OpenMP_C (missing: OpenMP_C_FLAGS OpenMP_C_LIB_NAMES) Seems something like mingw-w64-clang-x86_64-openmp in msys2 (https://packages.msys2.org/package/mingw-w64-clang-x86_64-openmp?repo=clang64) is missing in my container. Also I have no libomp.dll

Ranguvar commented on 2018-12-28 14:16

yay constantly alerts that this package is newer for me than on the AUR, which is annoying :p

Can this be renamed to -git? Not sure if that's what will take care of that warning.

I'll adopt the package if you like.

xantares commented on 2016-07-13 07:07

@abique, yes, even cooler would be for clang to support mingw exceptions first

abique commented on 2016-07-12 16:57

Would be cool to provide a clang toolchain for cmake.

xantares commented on 2016-02-05 13:44

@skystrife, any logs ? your patch may fix an issue but is not the canonical way of installing a package.

skystrife commented on 2016-02-05 12:32

Installing the package fails for me. The following changes allowed me to install successfully: https://gist.github.com/skystrife/b025fef7bf5e98b222a8

Schala commented on 2015-03-16 02:27

or rather renamed to mingw-w64-wclang