Package Details: mingw-w64-cgal 4.14-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-cgal.git (read-only)
Package Base: mingw-w64-cgal
Description: Computational Geometry Algorithms Library (mingw-w64)
Upstream URL: http://www.cgal.org
Licenses: LGPL, GPL,
Submitter: xantares
Maintainer: xantares
Last Packager: xantares
Votes: 1
Popularity: 0.000000
First Submitted: 2014-04-09 19:44
Last Updated: 2019-04-11 16:38

Latest Comments

calegria commented on 2017-08-18 18:02

@xantares

> wine is a makedepend

Sorry for that, my mistake. Nevertheless, it is already required by cmake.

> no need to add gmp: it is already pulled by mpfr

ok

> I prefer to enable all possible features ...

I was just following the PKGBUILD file from the cgal package. Building qt
takes a lot of effort so I would suggest to set it as optional.

Thanks for your answer

xantares commented on 2017-08-18 11:47

@calegria:
- about the prepare section: just read what the PR does, you can always try to build without if you do not agree
- wine is a makedepend
- no need to add gmp: it is already pulled by mpfr
- I prefer to enable all possible features, that's why I require qt, eigen

calegria commented on 2017-08-17 18:51

I am able to build cgal now. I was using a previous version of mingw-w64-cmake that did not contain wine as a dependency.

I modified the mingw-w64-cgal PKGBUILD file. I made qt5-sgv and eigen as optional dependencies (they are needed depending on the packages you will use), and gmp as a dependency (it is required to link programs against cgal libraries). I also added #Maintainer and #Contributor as required by the Arch Linux packaging standard. The PKGBUILD file is here, if you are willing to use it: https://gist.github.com/calegria/32036c615a01d9c2e5ecb842e5698642

Some other comments:
- I am not sure why the modification made on prepare() function are needed. They are not needed in the cgal (non mingw-w64) package.
- ¿Is it wine needed as a runtime dependency?

Thx.

xantares commented on 2017-08-16 19:21

indeed, wine should be installed

calegria commented on 2017-08-16 14:13

I am getting an error while building cgal. It seems that cmake is not finding the mingw-w64 include files. Here is the complete error: https://gist.github.com/calegria/66ada0e6c646a3a81e1ae329ba0f8583