Package Details: minetest-common-git 1:5.4.0.r267.g2866918f3-1

Git Clone URL: https://aur.archlinux.org/minetest-git.git (read-only, click to copy)
Package Base: minetest-git
Description: Common data files for minetest and minetest-server (git)
Upstream URL: https://www.minetest.net
Licenses: GPL
Conflicts: minetest-common
Provides: minetest-common
Submitter: None
Maintainer: y5nw
Last Packager: y5nw
Votes: 46
Popularity: 0.000024
First Submitted: 2011-09-27 12:43
Last Updated: 2021-07-28 15:55

Required by (16)

Sources (6)

Pinned Comments

y5nw commented on 2021-06-23 09:57

LevelDB and Redis support is only enabled for minetestserver. This is intended for consistency with the PKGBUILD of minetest in the official community repo, which, at the time of writing, only has LevelDB and Redis support enabled for the server. I do not know why they switched to Ninja for 5.4.1, but that's a different matter and should only affect the build process.

If you need a client with LevelDB and/or Redis support, please look at minetest-git-leveldb. If you need to change the database backend of an existing world, please refer to https://wiki.minetest.net/Database_backends

y5nw commented on 2021-03-18 12:39

The PKGBUILD should now use the MT fork of Irrlicht ("IrrlichtMt"). Note that

  • The irrlicht package is not needed to build Minetest anymore.

  • This package does not install IrrlichtMt library onto the system as the library is statically linked into the Minetest binary (i.e. if you have the irrlicht package installed, it will not be overwritten by IrrlichtMt).

  • IrrlichtMt may not necessarily be compatible with the upstream version of Irrlicht.

Latest Comments

1 2 3 4 5 6 Next › Last »

y5nw commented on 2021-06-23 09:57

LevelDB and Redis support is only enabled for minetestserver. This is intended for consistency with the PKGBUILD of minetest in the official community repo, which, at the time of writing, only has LevelDB and Redis support enabled for the server. I do not know why they switched to Ninja for 5.4.1, but that's a different matter and should only affect the build process.

If you need a client with LevelDB and/or Redis support, please look at minetest-git-leveldb. If you need to change the database backend of an existing world, please refer to https://wiki.minetest.net/Database_backends

FabioLolix commented on 2021-06-22 18:07

Hello, does this include levelDB?

y5nw commented on 2021-03-18 12:39

The PKGBUILD should now use the MT fork of Irrlicht ("IrrlichtMt"). Note that

  • The irrlicht package is not needed to build Minetest anymore.

  • This package does not install IrrlichtMt library onto the system as the library is statically linked into the Minetest binary (i.e. if you have the irrlicht package installed, it will not be overwritten by IrrlichtMt).

  • IrrlichtMt may not necessarily be compatible with the upstream version of Irrlicht.

katt commented on 2021-03-10 11:59

Disowning since I've lost interest in this + can't figure out the irrlicht crap. Sorry!

micwoj92 commented on 2021-03-04 13:04

@LuciRose431 just rebuild package. -git packages do not need bumps. A tip I can give is to watch GitHub rss feeds so you know when commits happen and when to rebuild.

micwoj92 commented on 2021-02-07 14:44

Thanks for update katt :D

vesath commented on 2021-02-03 00:05

No but I'm glad to orphan it so that someone else can. Happy maintaining!

micwoj92 commented on 2021-02-02 21:18

Hello vesath, could you update this PKGBUILD to look more like minetest from community repo?

vesath commented on 2019-03-12 22:58

There you go. Thanks for the suggestion.

EndlessEden commented on 2019-03-12 11:51

please add -DBUILD_SERVER=TRUE to the config and hiredis to the dependency list.