Package Details: midori-git 0.6.0.r8628.7b765721-1

Git Clone URL: https://aur.archlinux.org/midori-git.git (read-only, click to copy)
Package Base: midori-git
Description: Lightweight web browser based on WebKit and GTK3. Git development version.
Upstream URL: https://midori-browser.org/
Licenses: LGPL
Conflicts: midori, midori-gtk2-git
Provides: midori
Submitter: SolarAquarion
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 149
Popularity: 0.000000
First Submitted: 2018-10-28 14:20
Last Updated: 2020-12-06 02:19

Required by (15)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

xyproto commented on 2012-03-18 21:49

Added --disable-granite since midori does not compile if the granite package is installed. Changed the dependency on docutils to 'python2-docutils', because of the package rename.

xyproto commented on 2011-12-02 10:37

Added a dependency on libunique3.

xyproto commented on 2011-10-09 21:54

engored, thanks for testing. Added "midori-gtk2-git" for the gtk2 version. I assume it's just a matter of time before gtk3 will be enabled by default.

av6 commented on 2011-10-09 17:29

Sorry to bother again, but very recent git commit [1] disabled gtk3 by default. It's considered experimental yet, it seems.

On a related note, I've tried Midori with GTK3 and there were some bugs like no favicons on tabs, but the most important: flash wasn't working.

[1] http://git.xfce.org/apps/midori/commit/?id=b378554df2b1a72069a26d394046455aeb793d7c

xyproto commented on 2011-10-09 13:44

engored, thanks for noticing. Enabled gtk3 and updated the PKGBUILD. namcap displays no errors or warnings.

av6 commented on 2011-10-09 04:28

It now requires gtk3 and libwebkit3. You can either add them to depends or add --disable-gtk3 to waf configure.

xyproto commented on 2011-02-18 17:24

Updated the PKGBUILD as the temporary fix is no longer needed.

av6 commented on 2011-02-17 23:50

It builds without the fix now.

pyther commented on 2011-02-16 13:27

it may work but the far better solution is to use a patch fie. especially considering those two tools are not in the main repos or community!

xyproto commented on 2011-02-16 09:16

pyther, the package works now and the fix is only temporary.