Package Details: mididings-git r706.bbec99a-2

Git Clone URL: https://aur.archlinux.org/mididings-git.git (read-only)
Package Base: mididings-git
Description: A MIDI router and processor based on Python, supporting ALSA and JACK MIDI (python3 patched)
Upstream URL: http://das.nasophon.de/mididings/
Licenses: GPL
Conflicts: mididings
Provides: mididings
Submitter: BrainDamage
Maintainer: BrainDamage
Last Packager: BrainDamage
Votes: 0
Popularity: 0.000000
First Submitted: 2019-10-29 15:36
Last Updated: 2019-11-14 17:50

Dependencies (9)

Required by (0)

Sources (1)

Latest Comments

rralf commented on 2019-11-24 00:15

Ah, thanks for the hint, I missed that optional dependency. Hmm, is upstream mididings really dead? Did Dominic Sacre (dsacre, the creator) already give a statement?

It would really be sad if it was dead. I found no other software that would satisfy my requirements, and mididings is really a great and flexible midi router. And I'll probably also have to carry around some local changes for mididings, soon. So if we find some other people, and mididings is really dead, it's maybe time for mididings-ng...

At least some people on the mididings mailing list are still active. I already asked one of them if he knows about the maintenance state.

Ralf

BrainDamage commented on 2019-11-23 20:47

Do you see a chance to integrate your changes to the official mididings package?

Almost none, upstream last release is from 2012, and last commit in 2015, there's a pending pull request which contains half changes I did already and that never got merged, upstream is pretty much dead and the current 'git' package can be considered the stable/final release

could you please consider to add python-pyinotify as a dependency? E.g., mididings.extra.inotify wants it:

it's already listed as optional dependency to get that functionality

Your pkgver() is bad because the version will change if you build it a different day. It should only change when the upstream is updated. Thanks for your work BrainDamage

Thanks yourself for the fix

rralf commented on 2019-11-23 18:36

Hi,

could you please consider to add python-pyinotify as a dependency?

E.g., mididings.extra.inotify wants it:

File "/usr/lib/python3.8/site-packages/mididings/extra/inotify.py", line 18, in <module> import pyinotify as _pyinotify ModuleNotFoundError: No module named 'pyinotify'

Thanks! Ralf

rralf commented on 2019-11-20 20:39

Thanks a lot! I was carrying around my local pkgbuild.

Do you see a chance to integrate your changes to the official mididings package?

Terence commented on 2019-11-15 16:45

Thanks for your work BrainDamage :)

Terence commented on 2019-11-04 14:54

Your pkgver() is bad because the version will change if you build it a different day. It should only change when the upstream is updated.

Please useprintf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" when there are no tags.

For more information checkout https://wiki.archlinux.org/index.php/VCS_package_guidelines