Package Details: microsoft-edge-beta-bin 92.0.902.22-1

Git Clone URL: https://aur.archlinux.org/microsoft-edge-beta-bin.git (read-only, click to copy)
Package Base: microsoft-edge-beta-bin
Description: A browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier
Upstream URL: https://www.microsoftedgeinsider.com/en-us/download
Licenses: custom
Conflicts: edge, edge-beta, edge-beta-bin, microsoft-edge-beta
Provides: edge-beta, microsoft-edge-beta
Submitter: bittin
Maintainer: bittin (EsauPR)
Last Packager: EsauPR
Votes: 13
Popularity: 5.74
First Submitted: 2021-05-01 07:39
Last Updated: 2021-06-21 19:48

Required by (1)

Sources (3)

Latest Comments

1 2 Next › Last »

rajkrys commented on 2021-05-18 18:24

Yes, confirming - now it's working guys! Thanks for maintaining and quick assistance.. Switched back to Beta version.

EsauPR commented on 2021-05-18 18:15

I made a quick fix. Now support custom flags and should be put in ~/.config/microsoft-edge-beta-flags.conf.

bittin commented on 2021-05-18 16:56

@EsauPR added you as a Co-Maintainer now

EsauPR commented on 2021-05-18 16:30

@bittin I don't have too much experience but if you need help with the package maintenance I could help you.

rajkrys commented on 2021-05-18 16:13

Still getting this message from this package: ==> Starting package()... install: cannot stat 'microsoft-edge-beta.sh': No such file or directory ==> ERROR: A failure occurred in package(). Aborting... error making: microsoft-edge-beta-bin

Switching to DEV worked... now using Dev version.

bittin commented on 2021-05-18 03:55

fixed

EsauPR commented on 2021-05-17 23:07

Thanks @Lex-2008 I can figure now how it works.

@bittin in the PKGBLUID you call install for microsoft-edge-dev.sh but you renamed this wrapper and its content with the prefix microsoft-edge-beta to match with this package so it can't find the file.

Also you need to add it as source and its checksum. And inside this wrapper you exec for the binary in the wrong folder, it must be msedge-beta.

bittin commented on 2021-05-17 17:19

@Lex-2008 @EsauPR

Added that file now, not sure if i did it right however as this is my first PKGBUILD i created from scratch, would anyone of you help with being co-maintainers? that might know better how to do it

Lex-2008 commented on 2021-05-17 13:36

@EsauPR: re config file: not at the moment, as I see. If you compare PKGBUILD files for beta and dev, then you will see that unlike beta, dev has this code snippet on line 50:

# User flag aware launcher
install -m755 microsoft-edge-dev.sh "${pkgdir}/usr/bin/microsoft-edge-dev"

And indeed microsoft-edge-dev.sh reads $XDG_CONFIG_HOME/microsoft-edge-dev-flags.conf file.

I believe that replacing /usr/bin/microsoft-edge-beta symlink with a similar file will do the trick.

ESClaus commented on 2021-05-07 16:22

Jumping from dev to beta and lost the ability to use the web capture tool.