Package Details: micropython 1.11-1

Git Clone URL: https://aur.archlinux.org/micropython.git (read-only)
Package Base: micropython
Description: Python3 for microcontrollers, with stdlib. (unix version)
Upstream URL: http://micropython.org/
Licenses: MIT
Submitter: keenerd
Maintainer: keenerd
Last Packager: keenerd
Votes: 11
Popularity: 0.000102
First Submitted: 2014-06-03 23:11
Last Updated: 2019-08-14 10:10

Latest Comments

1 2 Next › Last »

keenerd commented on 2019-08-22 02:14

I have no idea. It built fine when I wrote it. Still builds fine here. I am also not seeing any smoking gun recent updates.

Alad commented on 2019-08-21 10:59

Didn't get the error below, but a different one in package_micropython-lib():

==> Installing ./types
Traceback (most recent call last):
  File "setup.py", line 1, in <module>
    from distutils.core import setup
  File "/usr/lib/python3.7/distutils/core.py", line 16, in <module>
    from distutils.dist import Distribution
  File "/usr/lib/python3.7/distutils/dist.py", line 9, in <module>
    import re
  File "/usr/lib/python3.7/re.py", line 122, in <module>
    import enum
  File "/usr/lib/python3.7/enum.py", line 2, in <module>
    from types import MappingProxyType, DynamicClassAttribute
ImportError: cannot import name 'DynamicClassAttribute' from 'types' (/home/user/.cache/aurutils/sync/micropython/src/micropython-lib-1.9.3/types/types.py)
==> ERROR: A failure occurred in package_micropython-lib().
    Aborting...

jeancf commented on 2019-08-13 19:18

CC ../../lib/utils/printf.c
../../lib/utils/printf.c:105:5: error: ‘__GI_vsnprintf’ specifies less restrictive attributes than its target ‘vsnprintf’: ‘nonnull’, ‘nothrow’ [-Werror=missing-attributes]
  105 | int __GI_vsnprintf(char *str, size_t size, const char *fmt, va_list ap) __attribute__((weak, alias ("vsnprintf")));
      |     ^~~~~~~~~~~~~~
In file included from ./mpconfigport.h:326,
                 from ../../py/mpconfig.h:62,
                 from ../../lib/utils/printf.c:27:
/usr/include/stdio.h:358:12: note: ‘__GI_vsnprintf’ target declared here
  358 | extern int vsnprintf (char *__restrict __s, size_t __maxlen,
      |            ^~~~~~~~~
CC build/frozen.c
cc1: all warnings being treated as errors
make: *** [../../py/mkrules.mk:47: build/lib/utils/printf.o] Error 1
make: *** Waiting for unfinished jobs....
==> ERROR: A failure occurred in build().
    Aborting...
Error making: micropython

dundee commented on 2017-11-10 17:23

==> Validating source files with md5sums...
    mpy-1.9.2.tgz ... Passed
    mlib-1.9.tgz ... Passed
    axtls-1.8.2.tgz ... Passed
    ffi-3.2.1.tgz ... Passed
    bdb.tgz ... FAILED

keenerd commented on 2017-01-27 01:57

Then you have something that is half and half released versions and random git commits.

If they want to use random git commits they should at least be included in the source tarball.

SpotlightKid commented on 2017-01-25 12:56

MicroPython releases are built against specific branches and commits of their sub-modules (you can see the commit hashes of the sub-modules when you look the micropython repo history for the release tag, i.e. for 1.8.7 here: https://github.com/micropython/micropython/tree/5653e3c72fc8555c6a060acf6447ac694a036053/lib). You can download tarballs for the sub-modules for these commits the same as for tagged releases.

Here's a PKGBUILD that uses the correct versions of the axtls and berkley-db-1.xx sub-modules and uses the system-installed libffi. For axtls to compile successfully you also need to turn off the -Werror compiler flag by passing CWARN="-Wall" to make.

https://gist.github.com/SpotlightKid/cafa2e84ab530ae3a9a4b57f8384b512

keenerd commented on 2017-01-24 18:09

Sorry about the delay. The entire 1.8.X release series has been a trainwreck of a refactor with most of the submodules broken or missing. Axtls was the worst, but I just noticed it can be built with mbedtls, and that fixes the blocker.

Patches welcome for getting the bundled Axtls library to work again.

keenerd commented on 2015-08-25 05:06

Fixed, and added the whole standard lib.

SpotlightKid commented on 2015-08-24 15:24

Please also install the 'pip-micropython' script to '/usr/bin'.

tee commented on 2015-05-03 14:32

no prob