Package Details: micro-bin 2.0.8-1

Git Clone URL: https://aur.archlinux.org/micro-bin.git (read-only, click to copy)
Package Base: micro-bin
Description: A modern and intuitive terminal-based text editor
Upstream URL: https://github.com/zyedidia/micro
Keywords: micro terminal-editor text-editor
Licenses: MIT
Conflicts: micro, micro-git, micro-nightly-bin
Provides: micro
Submitter: nycko123
Maintainer: nycko123
Last Packager: nycko123
Votes: 92
Popularity: 1.04
First Submitted: 2017-08-13 10:06
Last Updated: 2020-10-07 15:00

Pinned Comments

nycko123 commented on 2017-12-15 15:07

Former 'micro' was a binary as well, that's why it was merged into 'micro-bin'. The best way to build it from sources is to have a working golang environment already (e.x. GOPATHS exported, libraries etc.), otherwise setting this up from the beggining is a pain in the a*. Downloading 60MB of go package (300MB extracted) to compile binary less than 10MB? There is no interest for me to do it to be honest.

For all of you not willing to install binaries, the 'micro' package name is free to use, so everyone can adopt that package and maintain it. Feel free to do it, in a way you like it (i.e. from sources, no binary though).

micro-bin is what it is, a binary.

Latest Comments

« First ‹ Previous 1 2 3 4 5

nycko123 commented on 2017-06-04 16:59

Please update with this latest 1.2.0 PKGBUILD
https://github.com/nycko123/ArchLinux/blob/master/micro/PKGBUILD

sukso96100 commented on 2016-12-10 13:21

@sisto / Thank you for your report. next time, you can just Flag this package out-of-date.

sisto commented on 2016-12-09 20:07

version 1.1.3 fixes an important bug. https://github.com/zyedidia/micro/issues/484

blainester commented on 2016-09-05 09:55

A better solution would be to add it to optdepends since it isn't required to run Micro.

Just change line 10 to:
optdepends=('xclip: needed for copy/paste support')

sukso96100 commented on 2016-09-03 05:13

@tahayassen Ok. I will do that soon.

tahayassen commented on 2016-09-03 05:06

Please add xclip as a dependency. It's pretty essential as copying & pasting doesn't work without it.

xDShot commented on 2016-08-31 00:57

My another variant. It fully builds from sources instead of installing of pre-built binary:

https://gist.github.com/xDShot/8f1e3b03c41f666c0efee4fb3aa9ac89

blainester commented on 2016-08-30 22:55

The source was giving a 404 error.

I made an updated PKGBUILD here:
https://gist.github.com/blainester/69fa4c033609bc4a7a5f3087f4b7720b

I changed the source to the latest stable tarballs from github, added sha256sum checks, and cleaned it up a bit. Updates should only require changing the pkgver as well as the sha256sum lines from now on.