Package Details: meteor-js 1.5.1-1

Git Clone URL: https://aur.archlinux.org/meteor-js.git (read-only)
Package Base: meteor-js
Description: Full-stack JavaScript platform for developing modern web and mobile applications
Upstream URL: https://www.meteor.com
Keywords: javascript nodejs platform
Licenses: MIT
Submitter: morning_star
Maintainer: flacks
Last Packager: flacks
Votes: 17
Popularity: 0.791882
First Submitted: 2015-08-11 02:40
Last Updated: 2017-09-14 12:20

Latest Comments

boosterdev commented on 2017-05-29 08:53

can you update it? I did flag it at 1.4.4.2, now we at 1.4.4.3

http://boosterdev.ddns.net/git/boosterdev/autobuild-packages/src/master/meteor-js

cluxter commented on 2017-04-21 19:57

@flacks: Sorry but this package is poorly written. Reading the official script carefully would have let you understand how to install this software as it should be. Right now the PKGBUILD is not only bugged but clearly wrong about the installation process that it should follow.

I would prefer to be the maintainer if you agree.

flacks commented on 2017-04-21 19:19

If someone can recommend a way to arrange this package so that Meteor can be available globally, I would be more than glad to update it. From what I can tell so far, one would have to modify the `meteor` script itself, since if it does not detect a `~/.meteor` directory, it will re-download it and install Meteor there.

cluxter commented on 2017-04-21 18:15

I will be glad to maintain this package for Achlinux.

I have never maintained any package so far but I helped debugging this package in the past, and in one week I will use Meteor everyday because it will be my job to code with Meteor. So I definitely need this package to work all the time and this would be the perfect use case for me to learn more about how to maintain an AUR package. Plus from what I already saw this is not the hardest package to maintain, so I guess it's a good one to start on.

ArchangeGabriel commented on 2017-04-19 23:55

@flacks: Please fix the PKGBUILD to conform to Arch policy (see in the wiki). The orphaning was done in this purpose, not for someone to come in and bump pkgver.

marcs commented on 2017-02-18 13:05

Disowned, this packages is a mess, planned to fix it but didn't had enough time.

ArchangeGabriel commented on 2017-02-14 12:58

This PKGBUILD is strongly against Arch rules. So, either someone step up by the end of the week with a clean PKGBUILD and I’ll grant this person maintainer rights, or this package will be deleted.

darkbasic commented on 2017-02-11 14:38

Please bump to 1.4.3, thanks.

paulequilibrio commented on 2016-07-22 13:09

The future plans from MDG is to make possible install Meteor using npm, as you can see here:

https://forums.meteor.com/t/npm-install-meteor-meteor-client-as-a-npm-package/19563/2

paulequilibrio commented on 2016-04-19 20:26

@fryfrog this is how the Meteor official installer works. From https://install.meteor.com/

"This always does a clean install of the latest version of Meteor into your ~/.meteor, replacing whatever is already there. (~/.meteor is only a cache of packages and package metadata; no personal persistent data is stored there.)"

I tried to move Meteor from ~/.meteor to /opt/meteor but with no success.

All comments