Package Details: megasync 4.2.5-4

Git Clone URL: (read-only, click to copy)
Package Base: megasync
Description: Easy automated syncing between your computers and your MEGA cloud drive
Upstream URL:
Submitter: son_link
Maintainer: Kozeid
Last Packager: Kozeid
Votes: 334
Popularity: 3.55
First Submitted: 2014-09-01 18:12
Last Updated: 2019-10-17 16:08

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ix5231 commented on 2019-10-15 10:33

Workaround: Add -fpermissive to QMAKE_CXXFLAGS


diff --git a/PKGBUILD b/PKGBUILD
index 38d9165..0947609 100644
@@ -55,7 +55,7 @@ build() {

     # build megasync
     cd "../.."
+    qmake-qt5 "CONFIG += FULLREQUIREMENTS" "QMAKE_CXXFLAGS += -fpermissive"
     lrelease-qt5 MEGASync/

Stane1983 commented on 2019-10-08 16:48

Error while building on gcc 9.2.0:

google_breakpad/client/linux/handler/ error: 'int tgkill(pid_t, pid_t, int)' was declared 'extern' and later 'static' [-fpermissive] 107 | static int tgkill(pid_t tgid, pid_t tid, int sig) { | ^~~~~~

dnmodder commented on 2019-10-03 20:11

Can you change the source for tar.gz? yay marks it to me as a devel package and I think it's due to that.

alfa8my commented on 2019-09-05 06:03

I am trying to update this, but the package cannot be downloaded: "HTTP server doesn't seem to support byte ranges. Cannot resume."

Kozeid commented on 2019-08-03 17:22

Expired signatures are only used by packages from MEGA's official repositories. This AUR package is not affected.

linuxyz commented on 2019-08-01 08:16

The package was updated by the MEGA team due to signature expiry. See:

Infinite.New1 commented on 2019-07-05 14:24

The "gcc-libs" got updated to 9.1.0-2 with the latest stable updates (2019-07-03) so no more errors now...

GuyDuNigo commented on 2019-07-05 06:08

@CorruptComputer make and automake are in base-devel package group and are supposed to be installed when using AUR. So they shouldn't be added to the package dependencies.


And I don't have autogen installed but can still compile the package.

CorruptComputer commented on 2019-07-05 04:58

There are missing dependencies here, you need to add make, automake, and autogen to the dependencies, as without this these the build will fail.

Infinite.New1 commented on 2019-07-02 23:17

Tried a couple of things but always receiving this message :

could not satisfy dependencies: unable to satisfy dependency 'gcc-libs>=9.1.0' required by megasync

I have "gcc-libs 8.3.0-1" but I'm not able to upgrade to 9.x.x.

Thank you for your upcoming suggestions...