Package Details: mediaexpress 12.1-1

Git Clone URL: https://aur.archlinux.org/decklink.git (read-only, click to copy)
Package Base: decklink
Description: Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
Upstream URL: https://www.blackmagicdesign.com/support/family/capture-and-playback
Licenses: custom
Submitter: alub
Maintainer: goldensuneur
Last Packager: goldensuneur
Votes: 19
Popularity: 0.130856
First Submitted: 2015-10-03 15:38
Last Updated: 2021-05-21 06:08

Pinned Comments

goldensuneur commented on 2020-03-02 19:00

I finally had time to investigate the issue. It looks like that as of 11.5, the DesktopVideoHelper.service has to be running for the capture card to work properly.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

scaramanga commented on 2021-07-23 14:22

No device is recognized for me after upgrading the kernel from 5.12 to 5.13.4-arch1-1. Might be a regression in the kernel.

For now I have to fall back to LTS. Did anyone else experience that?

YAOMTC commented on 2021-07-16 20:36

Oh yes, I tested it with that, too. I also tried the card in Linux Mint, and on a different PC running Ubuntu 21.04, and then the first PC again but I had replaced Linux Mint with Ubuntu 20.04 LTS. Nothing but black capture with all of them, with a docked Nintendo Switch attached to it via HDMI. This may be a faulty unit, though the seller said it was never used. I'm corresponding with BMD now.

goldensuneur commented on 2021-07-16 07:47

Is the DesktopVideoHelper.service enabled and runnning ? I remember having weird issue like that when it is not.

Otherwise I won't be able to help you much. I don't own a blackmagic capture card anymore, my old one broke.

YAOMTC commented on 2021-07-15 21:38

I can't get my Intensity Pro 4K working. Desktop Video Setup detects it just fine (I wish this included some troubleshooting utility) but OBS doesn't see it. Here's where blackmagic shows up in dmesg:

blackmagic_io: loading out-of-tree module taints kernel.
blackmagic_io: module license 'Proprietary' taints kernel.
blackmagic_io: module verification failed: signature and/or required key missing - tainting kernel
blackmagic-io 0000:05:00.0: enabling device (0000 -> 0002)
BlackmagicIO: Intensity Pro 4K as blackmagic!io0 [0000:05:00.0]
BlackmagicIO: Initialised serial driver for blackmagic!io0

I could try the LTS kernel, but the drivers are being initialized, so maybe that's not the issue? What else should I try? I've tested /dev/video0 through /dev/video3 and found they were my other video devices (Index cameras & webcam). You'd think this would be /dev/video4 but it doesn't exist. EDIT: Using linux-lts didn't help. EDIT2: Neither did using Linux Mint. Using Media Express there just shows black. I'll try another PCIe slot. EDIT3: That didn't work either. I've emailed BMD support.

ericfont commented on 2021-04-06 00:52

Waking from suspend results in threads for "DesktopVideoUpdater" and two threads for "DesktopVideoHelper" consuming an entire 100% of a CPU each, for a total of 400% of a CPU being consumed. This performance bug has been reported to https://forum.blackmagicdesign.com/viewtopic.php?f=18&t=109244 DesktopVideoUpdater and DesktopVideoHelper and comments say it happens on Manjaro, Debian, Mint, and Arch.

I am also noting that video capture in OBS doesn't work on the realtime kernel (linux-rt)...simply produces a black image in OBS and freezes OBS.

lorddickfist commented on 2021-01-23 21:05

thanks for the info, will try that as soon as I figure out how :)

MAJOR EDIT: Was able to fix by switching to a different obs package. I ended up switching to obs-studio-browser. It doesn't seem to have anything missing from the original package, but it is updated to 26.1.1

daren commented on 2021-01-23 20:39

Wrote this a couple posts back before it got buried.

You need to update OBS to 26.1.1 by adapting the PKGBUILD.

For some reason the Arch repo version is still stuck at 26.1.0 containing a bug for Intensity cards (I had the all green thing as well).

lorddickfist commented on 2021-01-23 20:32

@daren can you share all of your obs settings for the blackmagic because I get the same issue after updating to 12.0

YUV doesn't show anything but green

daren commented on 2021-01-23 18:17

Yes, no issues using my Blackmagic Intensity Pro with OBS 26.1.1 feeding a 720p60 HDMI input.

Sebiann commented on 2021-01-23 17:53

@daren So you don't get the half purple half black screen?