Package Details: med 4.0.0-6

Git Clone URL: https://aur.archlinux.org/med.git (read-only, click to copy)
Package Base: med
Description: Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5. Without openmpi.
Upstream URL: https://www.salome-platform.org/downloads
Licenses: LGPL
Submitter: None
Maintainer: Nim65s
Last Packager: Nim65s
Votes: 97
Popularity: 2.75
First Submitted: 2007-09-25 18:28
Last Updated: 2020-04-28 08:16

Latest Comments

1 2 3 4 5 6 ... Next › Last »

dviktor commented on 2020-04-28 18:29

I have a lot of errors during package() funcs. Seems like it tries to modify system files directly instead of those placed in fakeroot. There is a log with informational lines only

Nim65s commented on 2020-04-27 09:26

I can reproduce that. I'll check if a new version of med is available, but their site is actually under maintainance.

Donald4444 commented on 2020-04-27 00:57

Agree with @bricem13

-- HDF5_VERSION=1.12.0
CMake Error at config/cmake_files/medMacros.cmake:402 (MESSAGE):
  HDF5 version is 1.12.0.  Only versions >= 1.10.2 are supported.
Call Stack (most recent call first):
  CMakeLists.txt:101 (MED_FIND_HDF5)

-- Configuring incomplete, errors occurred!

Problem is medMacros.cmake Line 401 (Checks if HDF is Version 1.10.x)

bricem13 commented on 2020-04-26 19:05

Unable to build

-- Found HDF5: /usr/lib/libhdf5.so;/usr/lib/libsz.so;/usr/lib/libz.so;/usr/lib/libdl.so;/usr/lib/libm.so (found version "1.12.0")  
-- Found HDF5 version 1.12.0 -- parallel flag is set to 
-- _versionComponents=1;12;0
-- HDF5_VERSION=1.12.0
CMake Error at config/cmake_files/medMacros.cmake:402 (MESSAGE):
  HDF5 version is 1.12.0.  Only versions >= 1.10.2 are supported.
Call Stack (most recent call first):
  CMakeLists.txt:101 (MED_FIND_HDF5)

-- Configuring incomplete, errors occurred!
See also "/home/brice/packages/med/src/med-4.0.0/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
    Aborting...

thupie commented on 2020-03-21 17:19

I got the following error while installing:

Symbol ‘med_penta18’ must be a PARAMETER in DATA statement at...

Fixed by first removing old 'med' package and some packages that were dependent on this, then installing again.

pacman -R med freecad

Banish commented on 2019-10-09 17:29

I get the following error msg:

/usr/bin/ld: cannot find -lsz
collect2: error: ld returned 1 exit status
make[2]: *** [src/CMakeFiles/medC.dir/build.make:1148: src/libmedC.so.11.0.0] Error 1
make[1]: *** [CMakeFiles/Makefile2:197: src/CMakeFiles/medC.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 86%] Building C object src/ci/CMakeFiles/_ci_static.dir/_MEDnFamilyGroup32.c.o
[ 86%] Building C object src/ci/CMakeFiles/_ci_static.dir/_MEDfamilyCr30.c.o
[ 86%] Building C object src/ci/CMakeFiles/_ci_static.dir/_MEDfamilyCr32.c.o
[ 86%] Building C object src/ci/CMakeFiles/_ci_static.dir/_MEDfamilyInfo30.c.o
[ 86%] Built target _ci_static
[ 86%] Built target medlink_swig_compilation
[ 86%] Built target medlocalization_swig_compilation
make: *** [Makefile:141: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Nim65s commented on 2019-08-25 20:58

@elgambitero: I just tried on a clean docker image and it compiled fine for me.

elgambitero commented on 2019-08-25 16:05

Hi. Compiling fails with

No rule to make target 'python/med/medsubdomain_modulePYTHON_wrap.cxx'

Not sure what to do. Can this be fixed by editing PKGBUILD?

greyltc commented on 2019-07-23 15:42

@Nim65s awesome! Thanks very much for fixing this up.

Nim65s commented on 2019-07-23 14:05

I adopted and updated med-openmpi.

@greyltc: done, thanks for the suggestion. @jedbrown: I think you should install med-openmpi if you want MEDparFileOpen() @alfredo.ardito: Sorry, you will have to either install hdf5 again instead of hdf5-openmpi, or go to med-openmpi.