Package Details: mcuxpresso-ide 11.0.1_2563-1

Git Clone URL: https://aur.archlinux.org/mcuxpresso-ide.git (read-only)
Package Base: mcuxpresso-ide
Description: An easy-to-use integrated development environment (IDE) for creating, building, debugging, and optimizing your application. From BIN package distributed by NXP.
Upstream URL: http://www.nxp.com/MCUXPresso
Keywords: IDE NXP
Licenses: custom:"NXP"
Submitter: gromain
Maintainer: gromain
Last Packager: gromain
Votes: 4
Popularity: 0.002444
First Submitted: 2017-03-29 14:09
Last Updated: 2019-09-16 13:18

Latest Comments

1 2 Next › Last »

ElektroQuark commented on 2019-09-05 16:28

Hi gromain,

11.0.1 is out.

irrfan798 commented on 2019-08-20 21:19

New sha256 for LICENSE is 0c183f71cf1d9bb45267a4cf74e9a2d536c751e22d0796238997573ed035fe10

jonny.Dumb commented on 2019-07-12 18:26

Hello, Installation failed due to the sha256sums check not passing for "LICENSE". Apologies for the Danish, but maybe there is some useful information in the error messages (Most is standard output, it found "mcuxpressoide-11.0.0_2516.x86_64.deb.bin" and "LICENSE" since this was the second time I ran the command):

$ aurman -S mcuxpresso-ide

~~ initializing aurman...

~~ calculating solutions...

:: The following 1 package(s) are getting installed: aur/mcuxpresso-ide / -> 11.0.0_2516-1

?? Do you want to continue? Y/n:

~~ looking for new pkgbuilds and fetching them...

==> Fremstiller pakke: mcuxpresso-ide 11.0.0_2516-1 (fre 12 jul 2019 20:06:15 CEST)

==> Tjekker runtime-afhængigheder...

==> Tjekker buildtime-afhængigheder...

==> Henter kilder ...

-> Fandt mcuxpressoide-11.0.0_2516.x86_64.deb.bin

-> Fandt LICENSE

==> Validerer source filer med sha256sums ...

mcuxpressoide-11.0.0_2516.x86_64.deb.bin ... Bestået

LICENSE ... FEJLEDE

==> FEJL: En eller flere filer bestod ikke validitetstjekket!

2019-07-12 20:06:16,071 - wrappers - makepkg - ERROR - makepkg query ['makepkg', '-cf', '--noconfirm'] failed in directory /home/[Username]/.cache/aurman/mcuxpresso-ide

ElektroQuark commented on 2018-09-08 19:49

V10.2.1 is out. Thank you.

ElektroQuark commented on 2018-01-10 06:34

V10.1.1 is out.

knutmithut commented on 2017-07-31 15:19

Regarding the LPCLink2 the only difference in the udev rules I found is this additional line in 85-mcuxpresso.rules:
KERNEL=="hidraw*", ATTRS{idVendor}=="1fc9", ATTRS{idProduct}=="0132", MODE="0666"

With lsusb I saw that the LPCLink2 after using it on windows is detected as
Bus 001 Device 002: ID 1fc9:000c NXP Semiconductors
which refers to the udev rule:
# LPC-Link (unbooted)
# NXP LPC
SUBSYSTEM=="usb", ATTRS{idVendor}=="1fc9", ATTRS{idProduct}=="000c", MODE="0666"

After running
$ /opt/lpcxpresso/bin/boot_link2
/opt/lpcxpresso/bin/dfu_boot -s ./boot_link2 -n LPC-Link2 -v 0x1fc9:0x000c -i /opt/lpcxpresso/bin/../bin/LPC432x_CMSIS_DAP_V5_134.bin.hdr
Looking for DFU devices...
dfu-util -d 0x1fc9:0x000c -c 0 -i 0 -t 2048 -R -D /opt/lpcxpresso/bin/../bin/LPC432x_CMSIS_DAP_V5_134.bin.hdr
Booted LPC-Link2 (0x1fc9:0x000c) with /opt/lpcxpresso/bin/../bin/LPC432x_CMSIS_DAP_V5_134.bin.hdr

the LPCLink2 is detected as
Bus 001 Device 009: ID 1fc9:0090 NXP Semiconductors
referring to
# NXP LPC-Link2 CMSIS-DAP
KERNEL=="hidraw*", ATTRS{idVendor}=="1fc9", ATTRS{idProduct}=="0090", MODE="0666"

and then MCUXpresso is able to detect it, too.

knutmithut commented on 2017-07-31 15:04

Reinstalled package on a new arch system and arm-none-eabi-gdb has run into the following error:
Could not determine GDB version using command: arm-none-eabi-gdb --version
arm-none-eabi-gdb: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

Solved by installing 'curses5-compat-libs'

gromain commented on 2017-07-17 12:40

Also, I just realised this is going to install in a new folder at /usr/local/mcuxpressoide-10.0.2_411 and will not replace in the old /usr/local/mcuxpressoide-10.0.0_344 .

Should I make the change to install in a dedicated mcuxpressoide folder (to preserve updates and addon installations)?

gromain commented on 2017-07-17 08:56

I just updated to the latest version.
I could not find where your problem came from @knutmithut, I'm sorry.
I don't own a LPCLink2 debugger unfortunately, so I can't test properly. Maybe it has to do with the udev rules. Can you check to content of /usr/lib/udev/rules.d/85-lpcxpresso.rules and compare it to the version installed by this package? (/usr/lib/udev/rules.d/85-mcuxpresso.rules)

knutmithut commented on 2017-06-30 22:57

Hey, last time I reinstalled this package after removing no longer needed packages from my system (including https://aur.archlinux.org/packages/lpcxpresso/) I noticed that MCUXpresso no longer finds my LPCLink 2 debugger, until I reinstalled lpcxpresso.
I have been using the debugger on Windows machines in between, and coming back to arch mcuxpresso wasn't able to detect it, until I booted it via /opt/lpcxpresso/bin/boot_link2 (source: https://community.nxp.com/thread/388964).
I'm not sure wether there is missing something in this package or in upstream. In latter case I will report to NXP.
Regards, Michael