Package Details: mcpelauncher-linux-git v0.1.beta.2.r11.gc2a2f53-1

Git Clone URL: https://aur.archlinux.org/mcpelauncher-linux-git.git (read-only)
Package Base: mcpelauncher-linux-git
Description: Minecraft: Pocket Edition launcher for Linux
Upstream URL: https://github.com/minecraft-linux/mcpelauncher-manifest
Keywords: minecraft
Licenses: custom, GPL3
Conflicts: mcpelauncher-client, mcpelauncher-server
Provides: mcpelauncher-client, mcpelauncher-server
Submitter: mrarm
Maintainer: mrarm
Last Packager: mrarm
Votes: 4
Popularity: 0.523078
First Submitted: 2018-08-23 17:39
Last Updated: 2018-12-20 19:46

Required by (1)

Sources (24)

Latest Comments

maximilian1003g commented on 2019-08-21 07:49

@zangoku Same issue. Now i use the Appimage Version, because that Version is working.

sjq commented on 2019-08-20 18:55

@zangoku same issue

zangoku commented on 2019-04-10 00:31

Getting this error when launching

20:29:50 Trace [Launcher] Loading Minecraft library terminate called after throwing an instance of 'std::runtime_error' what(): Failed to find data file: libs/libminecraftpe.so Signal 6 received Backtrace elements: 13

0 mcpelauncher-client(_ZN12CrashHandler12handleSignalEiPv+0xcc) [0x5666f8cc]
1 linux-gate.so.1(__kernel_sigreturn+0) [0xf7fad940]
2 linux-gate.so.1(__kernel_vsyscall+0x9) [0xf7fad929]
3 /usr/lib32/libc.so.6(gsignal+0xc2) [0xf7888082]
4 /usr/lib32/libc.so.6(abort+0xf0) [0xf78722b6]
5 /usr/lib32/libstdc++.so.6(+0x6b68b) [0xf7bae68b]
6 /usr/lib32/libstdc++.so.6(+0x72e67) [0xf7bb5e67]
7 /usr/lib32/libstdc++.so.6(+0x72ee3) [0xf7bb5ee3]
8 /usr/lib32/libstdc++.so.6(+0x73224) [0xf7bb6224]
9 mcpelauncher-client(+0x4608a) [0x5664508a]
10 mcpelauncher-client(main+0x13ac) [0x566492fc]
11 /usr/lib32/libc.so.6(__libc_start_main+0xf1) [0xf7873b41]
12 mcpelauncher-client(_start+0x31) [0x5664a0b1]

Dumping stack... [1] 18838 abort (core dumped) mcpelauncher-client

CyberShadow commented on 2018-10-30 17:22

Whoops, right - looks like I accidentally left the -git off of the name of this package.

mrarm commented on 2018-10-30 17:17

@CyberShadow I believe you have tried to build one of the similarly named other mcpelauncher packages, but they are outdated and deprecated. The directory mentioned by you in the comment has never been used by this particular package - please verify you are installing the correct package with your aur helper.

CyberShadow commented on 2018-10-29 18:52

Thanks for working on this. I'm getting a linking error, though:

[100%] Linking CXX executable mcpelauncher
/usr/sbin/ld: gplay_api/libgplayapi.a(gsf.pb.cc.o): in function `protobuf_gsf_2eproto::InitDefaults()':
gsf.pb.cc:(.text+0x3c8b): undefined reference to `google::protobuf::internal::InitSCCImpl(google::protobuf::internal::SCCInfoBase*)'
/usr/sbin/ld: gsf.pb.cc:(.text+0x3cab): undefined reference to `google::protobuf::internal::InitSCCImpl(google::protobuf::internal::SCCInfoBase*)'

(many more link errors follow.)