Package Details: maya 2017_UPDATE_4-1

Git Clone URL: https://aur.archlinux.org/maya.git (read-only, click to copy)
Package Base: maya
Description: Autodesk Maya 3D modelling software suite
Upstream URL: http://www.autodesk.com/products/maya/overview
Keywords: Autodesk Maya
Licenses: custom: unlimited
Submitter: aquarius
Maintainer: aquarius
Last Packager: z3ntu
Votes: 15
Popularity: 0.48
First Submitted: 2016-07-25 19:14
Last Updated: 2017-06-26 16:13

Pinned Comments

z3ntu commented on 2017-09-19 12:35

If anyone wants to take over this package (or become co-maintainer) I'll gladly give it to you.

sanya_rnd commented on 2017-06-04 00:26

These bugs can be easily fixed:

echo "MAYA_DISABLE_CIP=1" >> ~/maya/2017/Maya.env # w/o it maya segfaults
echo "LC_ALL=C" >> ~/maya/2017/Maya.env # w/o it maya gives singular matrix error

Also you need this to prevent constant Helvetica package errors:
xset +fp /usr/share/fonts/100dpi/
xset +fp /usr/share/fonts/75dpi/
xset fp rehash

After that, Bifrost will be telling about missing lib:
// Error: line 1: Unable to dynamically load : /usr/autodesk/maya2017/plug-ins/bifrost/plug-ins/bifrostshellnode.so
libtinfo.so.5: cannot open shared object file: No such file or directory //
// Error: line 1: libtinfo.so.5: cannot open shared object file: No such file or directory (bifrostshellnode) //

To fix that, install aur/libtinfo (symlink package to ncurses) and after that:
sudo ln -s /usr/lib/libtinfo.so.6 /usr/autodesk/maya2017/lib/libtinfo.so.5

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

naelstrof commented on 2017-08-17 21:20

The PKGBUILD needs QT4 added as a dependency, also for those of you who get an error like this while running the setup:
X Error: BadAccess (attempt to access private resource denied) 10
Extension: 130 (MIT-SHM)
Minor opcode: 1 (X_ShmAttach)
Resource id: 0x145

You can run the setup like this to fix it:
sudo QT_X11_NO_MITSHM=1 /opt/maya-setup/setup

t-ask commented on 2017-07-26 12:52

Please add/move the licence of this package to "${pkgdir}/usr/share/licenses/${pkgname}/".

sanya_rnd commented on 2017-06-04 00:26

These bugs can be easily fixed:

echo "MAYA_DISABLE_CIP=1" >> ~/maya/2017/Maya.env # w/o it maya segfaults
echo "LC_ALL=C" >> ~/maya/2017/Maya.env # w/o it maya gives singular matrix error

Also you need this to prevent constant Helvetica package errors:
xset +fp /usr/share/fonts/100dpi/
xset +fp /usr/share/fonts/75dpi/
xset fp rehash

After that, Bifrost will be telling about missing lib:
// Error: line 1: Unable to dynamically load : /usr/autodesk/maya2017/plug-ins/bifrost/plug-ins/bifrostshellnode.so
libtinfo.so.5: cannot open shared object file: No such file or directory //
// Error: line 1: libtinfo.so.5: cannot open shared object file: No such file or directory (bifrostshellnode) //

To fix that, install aur/libtinfo (symlink package to ncurses) and after that:
sudo ln -s /usr/lib/libtinfo.so.6 /usr/autodesk/maya2017/lib/libtinfo.so.5

z3ntu commented on 2017-05-04 07:42

More error messages:
Error: Singular matrix, no inverse exists
root : ERROR : code for hash md5 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type md5
root : ERROR : code for hash sha1 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha1
root : ERROR : code for hash sha224 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha224
root : ERROR : code for hash sha256 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha256
root : ERROR : code for hash sha384 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha384
root : ERROR : code for hash sha512 was not found.
Traceback (most recent call last):
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 147, in <module>
globals()[__func_name] = __get_hash(__func_name)
File "/usr/autodesk/maya2017/lib/python27.zip/hashlib.py", line 97, in __get_builtin_constructor
raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha512
Graphic device does not support OpenGL Core Profile, fallback to OpenGL renderer.
VP2 Error : Failed to initialize graphics device.

z3ntu commented on 2017-05-04 07:39

There are some python<->openssl issues that are probably caused by the update to openssl 1.1. I haven't managed to get many things working since.

YAOMTC commented on 2017-04-13 21:42

I fixed my problem (albeit on CentOS) by disabling consistent network device naming, and reverting to the old style of eth0.

z3ntu commented on 2017-04-06 06:40

Running the setup and choosing the default options destroyed pacman...

"pacman: symbol lookup error: /usr/lib/libssh2.so.1: undefined symbol: EVP_rc4"

EDIT: ugh sorry, the LD_LIBARY_PATH linked pacman to the autodesk openssl libs...
EDIT2: Another problem: lrwxrwxrwx 1 root root 63 6. Apr 08:32 /usr/bin/maya2017 -> /home/luca/aur/maya/pkg/maya/usr/autodesk/maya2017/bin/maya2017
But that file doesn't exist.
EDIT3: The following patch fixes the issue from EDIT2:

diff --git a/PKGBUILD b/PKGBUILD
index ef168b0..be1bd92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ package() {

mkdir -p "$pkgdir"/usr/bin/
chmod 755 "$pkgdir"/usr/bin/
- ln -s "$pkgdir"/usr/autodesk/maya2017/bin/maya2017 "$pkgdir"/usr/bin/maya2017
+ ln -s /usr/autodesk/maya2017/bin/maya2017 "$pkgdir"/usr/bin/maya2017

mkdir -p "$pkgdir"/usr/share/applications/
chmod 755 "$pkgdir"/usr/share/applications/

YAOMTC commented on 2017-03-26 03:05

I can't get this to work. I just get "command not found" for maya. I built the package, installed it, ran "export LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R12/lib64/", sudo ./setup, it fails (as expected?) with the "Could not launch rpm executable", and then... what next?

EDIT: The command for Maya 2017 is "maya2017" not "maya". However I get a new error now - "AdlmInt Error: The AUTODESK_ADLM_THINCLIENT_ENV XML file could not be loaded
maya: Autodesk Maya 2017Licensing ErrorA licensing error occurred that Autodesk systems were not able to handle for you. Please contact Autodesk Customer Support for help in resolving this error.GetFeatureAuthorizationStatus 6 (Initialization Error)"

QuartzDragon commented on 2016-11-25 23:46

@aquarius

Perhaps so, however, Maya 2017 can also be acquired for free via a student licence, which, as far as I know, as no limits.

aquarius commented on 2016-11-25 22:14

Hello everybody! We need an explanation.

1) maya developers(Autodesk) provide free educational license (full functional) only for 2016.

2) Not everything can be done in the PKGBUILD. Because user need to obtain a personal license key to register. Then put it into console license installer.

3) Register any licenses (for 2016 or 2017) also required to run GUI applications that can not be done from the PKGBUILD

I was looking for ways how to simplify (real arch way) the installation of an educational (one-seat) license in 2016, but did not really find it.