Package Details: mavproxy-git r2216.435a1b06-1

Git Clone URL: https://aur.archlinux.org/mavproxy-git.git (read-only, click to copy)
Package Base: mavproxy-git
Description: MAVLink proxy and command line ground station.
Upstream URL: http://ardupilot.github.io/MAVProxy/html/index.html
Licenses: GPL3
Conflicts: mavproxy
Provides: mavproxy
Submitter: applebloom
Maintainer: acxz
Last Packager: acxz
Votes: 2
Popularity: 0.019149
First Submitted: 2016-04-05 15:52
Last Updated: 2020-04-25 14:43

Pinned Comments

acxz commented on 2020-04-19 14:16

Development is on Github: https://github.com/acxz/pkgbuilds Please open issues and PRs there instead of commenting.

Latest Comments

acxz commented on 2020-04-19 14:16

Development is on Github: https://github.com/acxz/pkgbuilds Please open issues and PRs there instead of commenting.

applebloom commented on 2020-03-22 21:53

I've no idea. I vaguely remember mavporoxy only working with python 2, but that was years ago.

acxz commented on 2020-03-22 21:49

Is it possible to use the python-pymavlink as a dep instead of python2-pymavlink-git?

acxz commented on 2020-03-22 21:47

I see, thx @applebloom!

applebloom commented on 2020-03-22 20:28

I don't think so. The python-* naming scheme is used for library packages. This package contains a command-line application called mavproxy (used to simulate mavlink-compatible vehicles), and as such should not use the scheme (compare e.g. deluge or meld, two other applications written in python).

acxz commented on 2020-03-21 23:37

Should this package be renamed to python-mavproxy-git?

applebloom commented on 2018-02-18 12:25

python2-future is now a dependency of python2-pymavlink-git, so it's not needed here. I've updated the version though.

I'm disowning mavlink related packages, as I don't use them now, and don't have access to a mavlink device like I use to have, so I can't even test them. Please feel free to take it, and sorry for the inconvenience.

patrickelectric commented on 2017-08-07 19:30

Add python2-future

petronny commented on 2017-03-07 06:06

Hi, this package has following makedepends:
python2-setuptools, git
please add them