Package Details: mathematica 12.0.0-1

Git Clone URL: https://aur.archlinux.org/mathematica.git (read-only)
Package Base: mathematica
Description: A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
Upstream URL: http://www.wolfram.com/mathematica/
Licenses: proprietary
Submitter: Feanor12
Maintainer: JP-Ellis
Last Packager: JP-Ellis
Votes: 63
Popularity: 1.845711
First Submitted: 2011-03-03 21:27
Last Updated: 2019-09-12 03:52

Dependencies (61)

Required by (1)

Sources (1)

Pinned Comments

JP-Ellis commented on 2019-04-24 05:41

Update to Mathematica 12.0.0

Summary of new features: https://wolfr.am/new-features-12

Please let me know if you encounter any issues.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

JP-Ellis commented on 2018-06-06 01:37

@vsilv Please have a look at some of the optional dependencies as some might be required for correct graphical display. (They are not marked as required as some users might only want to use the command-line version of Mathematica).

vsilv commented on 2018-06-05 17:07

Dear JP-Ellis, Even though it was possible to install mathematica using the PKGBUILD, running it for the first time creates a activation screen with flawed buttons; in particular, the activate button does not work. Where could I search for the error? Both building the .pkg.tar and installing worked out without errors. vsilv

WeeTC commented on 2018-05-30 09:24

@JP-Ellis Ok, so the saga is over ( for now ... :) ). The installation, after installing portaudio, is now fine (the option to install without the documentation turned out to be important for me as well - thanks).

JP-Ellis commented on 2018-05-30 04:34

@WeeTC Thanks for the update. It appears Wolfram released a new version of Mathematica 11.3.0 (though with no release notes). I've updated the checksums and it should build fine now.

WeeTC commented on 2018-05-29 06:25

@JP-Ellis

Unfortunately, I tried this and I got "One or more files did not pass the validity check! " as an error message.

Is the installer up to date?

JP-Ellis commented on 2018-05-29 03:44

@WeeTC You ideally should clone/download a snapshot of the AUR package into a directory, copy (or link) Mathematica in the same directory and then use makepkg to build the full package which can then be installed with pacman -U package_name.tar.xz.

In the case of pacaur, by default it will clone the AUR package into ~/.cache/pacaur so you could copy (or link) Mathematica into ~/.cache/pacaur/mathematica.

WeeTC commented on 2018-05-28 11:42

Hey,

Running "pacaur -S mathematica" in the directory with the files:

(output of ls -l)" total 4845616 -rw-r--r-- 1 weetc users 2695 Apr 11 07:06 duplicate-libs.txt drwxr-xr-x 7 root root 4096 May 18 16:14 Install -rw-r--r-- 1 weetc users 4961862431 May 12 14:27 Mathematica_11.3.0_LINUX.sh -rw-r--r-- 1 weetc users 22314 Apr 11 07:06 PKGBUILD drwxr-xr-x 2 weetc users 4096 May 12 14:50 src " produces " ==> ERROR: Mathematica_11.3.0_LINUX.sh was not found in the build directory and is not a URL. :: failed to verify mathematica integrity ".

Have I made a simple mistake here?

Thanks,

TC

Lchu613 commented on 2018-04-11 18:33

As jumper149 pointed out, having portaudio installed is now necessary for 11.3.0-2 to run; otherwise everything runs fine.

jumper149 commented on 2018-04-11 08:36

i had to install portaudio but now it works. Maybe this shouldnt be optional.

Keep up the good work!

qft commented on 2018-04-11 06:25

I do not use text-to-speech functionalities. I just do not like the fact that some features that were working before become broken for no added benefit. For people who do reply on the affected features, they would have to install new dependencies that they don't need before. This is a net loss.

Anyways, thank you for maintaining the package.