Package Details: mathematica 12.1.1-1

Git Clone URL: https://aur.archlinux.org/mathematica.git (read-only, click to copy)
Package Base: mathematica
Description: A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
Upstream URL: http://www.wolfram.com/mathematica/
Licenses: proprietary
Submitter: Feanor12
Maintainer: JP-Ellis
Last Packager: JP-Ellis
Votes: 71
Popularity: 0.58
First Submitted: 2011-03-03 21:27
Last Updated: 2020-08-08 03:57

Dependencies (50)

Required by (1)

Sources (1)

Pinned Comments

JP-Ellis commented on 2020-04-02 23:34

Update to Mathematica 12.1.0

Summary of new features: https://wolfr.am/NewIn12.1

Please let me know if you encounter any issues.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

JP-Undercover commented on 2019-09-11 11:20

Installing this package on Manjaro ended up with this:

Installation failed. See
/home/undercover/.cache/yay/mathematica/pkg/mathematica/opt/Mathematica/InstallErrors.

  -> Errors related to 'xdg-icon-resource' and 'xdg-desktop-menu' are to be expected during Mathematica's installation.
  -> Fixing symbolic links
rm: cannot remove 'wolframscript': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
Error making: mathematica

The file InstallErrors is empty.

sfncmp1729 commented on 2019-06-24 15:09

Any news about the Wolfram Engine AUR package?

JP-Ellis commented on 2019-06-09 00:28

@bryango Thanks! I've updated the PKGBUILD. Note that I have not updated the release number as this is such a minor change and most people will get this at the next update.

bryango commented on 2019-06-08 13:45

@JP-Ellis Adding StartupWMClass=Mathematica to the desktop file will greatly improve the window management experience (e.g. the window will now use themed icons set in the system). Strongly recommended!

JP-Ellis commented on 2019-06-03 00:36

@dareme7 All the AUR packages always assume that the base and base-devel groups are installed (and sed is in fact a member of both... indicating that somehow you don't even have the base group installed which contains essential software for Linux systems).

dareme7 commented on 2019-06-01 14:47

This package is missing sed as a dependancy, it won't start otherwise.

sfncmp1729 commented on 2019-05-23 13:29

@JP-Ellis Thanks for your work!

JP-Ellis commented on 2019-05-23 03:16

@sfncmp1729 I'll have a look at creating a PKGBUILD for the Wolfram Engine soon. I'll have to play around with it and make sure it works first which might take a day or two, but hopefully by the end of this weekend I should have something up!

sfncmp1729 commented on 2019-05-22 13:19

Hi! A free version of the Wolfram Engine for developers has been released (https://www.wolfram.com/engine/). Just wondering, would it be possible to adapt this PKGBUILD for it?

RunAndTumble commented on 2019-04-30 14:18

@JP-Ellis

Yes, I didn't notice that I was out of space, thank you.