Package Details: mastodon 3.1.4-1

Git Clone URL: https://aur.archlinux.org/mastodon.git (read-only, click to copy)
Package Base: mastodon
Description: Self-hosted social media and network server based on ActivityPub and OStatus
Upstream URL: https://github.com/tootsuite/mastodon
Licenses: AGPL3
Submitter: flacks
Maintainer: None
Last Packager: liolok
Votes: 6
Popularity: 0.21
First Submitted: 2018-06-19 19:35
Last Updated: 2020-05-15 15:22

Pinned Comments

liolok commented on 2020-05-25 03:40

An advise from previous packager (not maintainer):

Do use Docker, let this package rest in peace. (Unless you are able to take cover all the upstream sh*t)

Latest Comments

1 2 Next › Last »

liolok commented on 2020-05-25 03:40

An advise from previous packager (not maintainer):

Do use Docker, let this package rest in peace. (Unless you are able to take cover all the upstream sh*t)

TheGoliath commented on 2020-04-04 19:37

Running makepkg --clean --syncdeps --noconfirm /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 19: syntax error near unexpected token <' /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 19: nodejs<=12.16.1' /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 20: nodejs: command not found /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 21: postgresql: command not found /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 22: redis: command not found /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 23: ruby-bundler: command not found /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 24: protobuf: command not found yarn install v1.22.4 info No lockfile found. [1/4] Resolving packages... [2/4] Fetching packages... [3/4] Linking dependencies... [4/4] Building fresh packages... success Saved lockfile. Done in 0.09s. /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 26: syntax error near unexpected token )' /home/builduser/.cache/aurutils/sync/mastodon/PKGBUILD: line 26: zlib)

count0 commented on 2020-03-05 20:49

Does not seem to be working with newer ruby 2.7... Does not build.

hhirtz commented on 2019-03-04 22:17

Gemfile.lock should not be removed: https://github.com/tootsuite/mastodon/issues/8983#issuecomment-437533243

diff --git a/PKGBUILD b/PKGBUILD
index 8eb9f76..f47195d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,10 +38,9 @@ sha512sums=('1829f16a5f98d1815168c8ecfd80b75bb3489e7b3e5eb06a858b0d35bdecc5a4542

 build() {
   cd mastodon-$pkgver
-  rm Gemfile.lock
-  bundle lock --update
-  bundle install --deployment --without development test
+  sed -i "s/1.17.3/$(bundle --version | cut -d' ' -f3)/g" Gemfile.lock
+  bundle install -j$(getconf _NPROCESSORS_ONLN) --deployment --without development test
   yarn config set ignore-engines true
   yarn install --pure-lockfile
 }

fbrennan commented on 2018-12-20 00:41

I'm not interested in fixing the namcap errors. Most of them are wrong anyway - namcap can't tell, but yes ffmpeg and magick are both used. Others would require that each Node module and Ruby gem be itself individually packaged and required instead of downloaded and built. Just by the nature of Node versioning that would be a nightmare to deal with.

buzo commented on 2018-12-19 16:28

Did you run namcap on the resulting package? It produces a huge amount of warnings and errors, see this paste.

Also, please rename the source tarball, preferably like this:

source=("$pkgname-$pkgver.tar.gz::<https://github.com/tootsuite/mastodon/archive/v>$pkgver.tar.gz"

fbrennan commented on 2018-12-11 04:43

Thank you @luka-devnull :-)

And for your previous comments as well. Helped me update the package after your first flag.

luka-devnull commented on 2018-12-08 09:31

v2.6.5 is out, which fixes a bug with yarn yanking packages in the pre v2.6.4 releases (including v2.6.2)

It's as easy as just updating the version number and the sha512sum though.

luka-devnull commented on 2018-11-09 03:45

You should also include libidn as a dependency. It doesn't build without it.

count0 commented on 2018-09-07 14:50

I'm getting the following build error when trying to upgrade to 2.5.0:

[1/6] Validating package.json... error mastodon@: The engine "node" is incompatible with this module. Expected version ">=8". error Found incompatible module info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. ==> ERROR: A failure occurred in build(). Aborting... :: failed to build mastodon package(s)