Package Details: mapillary_tools-git r1316.496deac-1

Git Clone URL: (read-only, click to copy)
Package Base: mapillary_tools-git
Description: Library for processing and uploading geotagged images to Mapillary
Upstream URL:
Licenses: BSD
Submitter: jose1711
Maintainer: gileri
Last Packager: gileri
Votes: 0
Popularity: 0.000000
First Submitted: 2018-07-09 15:01
Last Updated: 2021-07-13 06:55

Latest Comments

1 2 Next › Last »

gileri commented on 2021-07-13 07:03

Done, thank you @jose1711 for the reminder !

jose1711 commented on 2021-07-12 08:35

please update maintainer/contributor info in the header. thank u

jose1711 commented on 2021-03-11 13:25

@gileri, thank you too. it's now available for adoption. have fun, j

gileri commented on 2021-03-10 17:07

@jose1711 Yeah totally ! Thanks.

jose1711 commented on 2021-03-09 20:36

@gileri hey, to be honest i don't currently have time to maintain this. any interest in adopting?

gileri commented on 2021-03-06 20:50

You're right, python-pymp4 has an hard dependency on python-construct 2.8.8.

There is a small (undocumented on the project) dependency from mapillary_tools on python-construct (the exceptions I cited). In addition, mapillary_tools depends on python-pymp4.

Right now, this AUR packages requires python-construct=2.8.10, while pymp4 depends on 2.8.8, so mapillary-tools is not installable as of now.

I created python-construct-288 and pushed an update to python-pymp4 to depend on it.

I think the best avenue would be to pin python-construct to >=2.8,<2.9 on this package. What do you think ?

jose1711 commented on 2021-02-28 11:20

With the latest python-construct I am getting:

  File "/usr/lib/python3.9/site-packages/pymp4/", line 86, in <module>
    "major_brand" / String(4),
NameError: name 'String' is not defined

Can you please detail your suggestion (maybe removing option to import gpx from blackvue)? Thanks

gileri commented on 2021-02-28 09:06

Hi, thanks for the quick update !

'python-construct=2.8.10' is listed as a dependency (twice), that prevents building the package as the current version in arch repos is 2.10.61-1.

As the library usage seems really limited, I think that the risks of API breakage are low :

So I would suggest removing the version pinning on python-construct.

gileri commented on 2021-02-27 11:26

Python 3 support has been implemented, and python 2 dropped :

jose1711 commented on 2020-07-25 12:13

At this moment this requires pymp4's dependency python-construct to be in a specific version (hence updated dependencies). Here's how I do this on my system:

svn checkout --depth=empty svn://
cd community
svn update python-construct
cd python-construct/trunk/

svn update -r r203452
makepkg --nocheck -si

Add python-construct and python2-construct into IgnorePkg (/etc/pacman.conf).