Package Details: mailspring 1.6.3-1

Git Clone URL: https://aur.archlinux.org/mailspring.git (read-only)
Package Base: mailspring
Description: A beautiful, fast and maintained fork of Nylas Mail by one of the original authors.
Upstream URL: https://getmailspring.com/
Keywords: email mail multiple-accounts nylas
Licenses: custom: GPL3 and (C) 2016-2019 Foundry 376, LLC.
Submitter: jnylen
Maintainer: dbalan (rashintha, jnylen)
Last Packager: jnylen
Votes: 110
Popularity: 6.014294
First Submitted: 2017-10-06 10:00
Last Updated: 2019-07-02 02:15

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

jnylen commented on 2018-08-12 21:04

@jenz, Then update. 1.4.0 was uploaded 3 days ago. Not sure why you get that message.

Please check https://github.com/Foundry376/Mailspring/releases next time when you flag.

aksh1618 commented on 2018-08-11 10:36

@rocka commented a PKGBUILD at Typora, which fixed it by packaging it with system electron. Could something like that be done with Mailspring?

Pauligrinder commented on 2018-08-09 08:15

Latest version (still requires the older glibc):

_pkgver=1.4.0

sha256sums_x86_64=('ed1503d36be45376d15c5ec35a2d8dab5ef8b07b318e9578ce9b5ea42c3ed528')

jamesbrink commented on 2018-08-08 02:02

Same workaround that is posted for slack (which is also broken) works with mailspring

grab glibc-2.27 from archive

https://archive.archlinux.org/packages/g/glibc/glibc-2.27-3-x86_64.pkg.tar.xz

mkdir /opt/glibc-2.27
sudo bsdtar xf /var/cache/pacman/pkg/glibc-2.27-3-x86_64.pkg.tar.xz --cd /opt/glibc-2.27

sudo patchelf --set-interpreter /opt/glibc-2.27/usr/lib/ld-linux-x86-64.so.2 --set-rpath \$ORIGIN:\$ORIGIN/lib/:/opt/glibc-2.27/usr/lib/ /usr/bin/mailspring

Pryka commented on 2018-08-06 06:51

EDIT: https://bugs.archlinux.org/task/59550

For some days now I can't run Mailspring. I get core dump all the time:

Process XXXX (mailspring) of user 1000 dumped core.
Stack trace of thread 2415:
0  0x0000000000a4fa30 n/a (mailspring)

GDB:

Starting program: /usr/bin/mailspring 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault. 0x0000000000a4fa30 in ?? () (gdb) bt full 0 0x0000000000a4fa30 in () 1 0x00007ffff7d832b2 in node::http2::Http2Session::Callbacks::Callbacks(bool) () at /usr/share/mailspring/libnode.so 2 0x00007ffff7d83375 in () at /usr/share/mailspring/libnode.so 3 0x00007ffff7fe36da in call_init.part () at /lib64/ld-linux-x86-64.so.2 4 0x00007ffff7fe37da in _dl_init () at /lib64/ld-linux-x86-64.so.2 5 0x00007ffff7fd503a in _dl_start_user () at /lib64/ld-linux-x86-64.so.2 6 0x0000000000000001 in () 7 0x00007fffffffea7c in () 8 0x0000000000000000 in ()

It started to behave like this after some Arch updates. Can't pinpoint exactly which one.

simeonoff commented on 2018-06-02 06:14

I get the following when trying to install:

==> Making package: mailspring 1.2.2-1 (Sat 02 Jun 2018 09:09:24 AM EEST)
==> Checking runtime dependencies...
==> Installing missing dependencies...
/usr/bin/pacman: unrecognized option '--color never'
==> ERROR: 'pacman' failed to install missing dependencies.
:: failed to build mailspring package(s)

pacman version 5.1.0

jnylen commented on 2018-05-18 19:26

@salkiran, I follow the stable releases from https://github.com/Foundry376/Mailspring/releases

Which also is the one that notify users of outdated versions.

saikiran commented on 2018-04-09 08:42

I think this package is obsolete from the master, it needs to be updated to the latest version of mailspring.

jnylen commented on 2018-02-04 14:51

Thanks RemoteAdmin, I have just pushed an update.

RemoteAdmin commented on 2018-02-04 05:23

I have executed readelf -d against the package and I have found two dependencies that are missing:

"gtk2" "nss"

If you add them, then you can also remove the following libraries as they are dependencies of the upper ones:

"icu" "libxext" "openssl" "libxtst" "glib2" "glibc" "libxml2" "libutil-linux"

The new dependes array therefore should be:

depends=("libgnome-keyring" "gnome-keyring" "libxss" "libtool" "c-ares" "ctemplate" "tidy" "libxkbfile" "libsecret" "gconf" 'gtk2' 'nss')

Also to verify my claim, the following contains the list of libraries requiring the new dependencies:

/usr/share/mailspring/mailspring needs libgtk-x11-2.0.so.0
/usr/share/mailspring/mailspring needs libgdk-x11-2.0.so.0
/usr/share/mailspring/mailspring needs libnss3.so
/usr/share/mailspring/mailspring needs libnssutil3.so
/usr/share/mailspring/mailspring needs libsmime3.so