Package Details: magic-wormhole 0.12.0-1

Git Clone URL: (read-only, click to copy)
Package Base: magic-wormhole
Description: Securely transfer data between computers
Upstream URL:
Licenses: MIT
Conflicts: python-wormhole, wormhole, wormhole-server
Provides: python-wormhole, wormhole, wormhole-server
Replaces: python-wormhole, wormhole, wormhole-server
Submitter: stormdragon2976
Maintainer: stormdragon2976
Last Packager: stormdragon2976
Votes: 29
Popularity: 1.74
First Submitted: 2016-08-10 22:29
Last Updated: 2020-04-05 15:51

Latest Comments

1 2 3 Next › Last »

stormdragon2976 commented on 2020-04-13 16:59

I was expecting this to be resolved shortly, but the python-twisted package in extra is still out of date. Until it is updated, the solution is to build it by hand. Using yay -G twisted, I was able to download the latest version and build it successfully.

DuBistKomisch commented on 2020-04-08 01:00

pkg_resources.ContextualVersionConflict: (Twisted 19.10.0 (/usr/lib/python3.8/site-packages), Requirement.parse('twisted>=20.3.0'), {'autobahn'})

FYI you currently need to install python-twisted from testing to get 0.12.0 to run, hopefully lands in stable soon.

kseistrup commented on 2019-03-28 15:36

The description for python-ipaddress reads “Python 3.3's ipaddress for older Python versions”. The ipaddress module is already there in Python3. Please remove the dependency.

VincentShaent commented on 2019-02-16 20:06

Thank you for reverting it to python3 only, @stormdragon2976!

stormdragon2976 commented on 2019-02-16 19:04

@nac: I changed the package back to a single version using python3. The python2 version never worked right anyway, and other people have had trouble with it too. Hopefully this will work better. Now it's back to being "magic-wormhole" like it started life as in the first place.

nac commented on 2019-02-16 01:59

Trying to install this package results in:

loading packages...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python2-magic-wormhole and python-magic-wormhole are in conflict

I'm not sure where python2-magic-wormhole is coming from.

stormdragon2976 commented on 2018-12-10 15:38

@rafaelff: Thanks, that should be fixed now.

rafaelff commented on 2018-12-10 15:30

in function package_python2-magic-wormhole (), PKGBUILD is set to enter:

     cd "${srcdir}/${_pkgname}-${pkgver}"

when should be

     cd "${srcdir}/${_pkgname}-${pkgver}"-py2

stormdragon2976 commented on 2018-12-10 15:27

I am not able to reproduce the problems, except, trying to install it as a group would cause a conflict because they both provide the same "wormhole" command. I have submitted a request for help on the PKGBUILD to the AUR list. Hopefully we can get this resolved soon. I apologize for any inconvenience. If you don't mind running git packages, magic-wormhole-git is python3 only, and should work without issue.

VincentShaent commented on 2018-12-07 22:38

I concur with trickyelf and aurelieng. Using yay, there were errors building the python 2 version when using magic-wormhole and python-magic-wormhole. Upon editing the pkgbuild and removing everything associated with "python2" the process was able to complete sucessfully.