Package Details: maestral 1.2.2-1

Git Clone URL: https://aur.archlinux.org/maestral.git (read-only, click to copy)
Package Base: maestral
Description: A light-weight and open-source CLI Dropbox client.
Upstream URL: https://github.com/SamSchott/maestral
Keywords: dropbox maestral python
Licenses: MIT
Conflicts: maestral-git
Provides: maestral
Submitter: coxackie
Maintainer: coxackie (bbaserdem)
Last Packager: coxackie
Votes: 2
Popularity: 0.47
First Submitted: 2020-04-18 08:50
Last Updated: 2020-12-02 17:24

Pinned Comments

coxackie commented on 2020-12-02 18:27

After the recent python 3.9 update: If maestral gives you an error, it is because some of the AUR packages is depends on (bugsnag, pyro5, dbus-next and sdnotify) need to be built again the latest python version. Either do this manually, or bug the maintainers to update. :)

Latest Comments

longstation commented on 2020-12-04 04:27

Hi @coxackie, thanks for the advice. Some additional info: I think you just need to rebuild pyro5 and sdnotify.

Update: I was wrong. All four are required.

coxackie commented on 2020-12-02 18:27

After the recent python 3.9 update: If maestral gives you an error, it is because some of the AUR packages is depends on (bugsnag, pyro5, dbus-next and sdnotify) need to be built again the latest python version. Either do this manually, or bug the maintainers to update. :)

coxackie commented on 2020-11-11 09:55

Version 1.2.2 will appear soon as dropbox gets updated to 3.9

coxackie commented on 2020-09-26 10:55

python-dropbox has been updated in the Arch repo. Also, dbus-next has been updated. The new maestral version 1.2.1 should be updating OK. You may be asked to get a new token from dropbox, as this version introduces sqlite indexing. To be as safe as possible, it may be a good idea to stop maestral during update.

bbaserdem commented on 2020-09-25 16:51

Yes; the dbus-next and the new python version requirement was not included in the changelogs by the developer; so they escaped scrutiny. (On August 20 jeepney was changed to dbus-next). I could have sworn I saw the dbus-next on the community repo; but I was mistaken. I'm trying to take over the package on AUR; since it has been out of date for two releases consecutively.

In the meantime I created the python-dbus-next-git package which should be version compliant.

For python-dropbox; https://github.com/dropbox/dropbox-sdk-python are not updating their repo tags for a few years; so I'm unsure how to create a git versioning package for python-dropbox. We should nag Lukas Fleischer somehow.

longstation commented on 2020-09-18 05:08

@coxackie Thanks for the quick update. I will upgrade when dependencies are satisfied.

coxackie commented on 2020-09-17 08:52

@longstation thanks, we were a bit quick to try to update this. As you will see, python-sqlalchemy has been added to dependencies; however, as of this point, both python-dbus-next and python-dropbox dependencies are not satisfied as the packages are out of date. Hopefully, this will be resolved soon.

longstation commented on 2020-09-16 21:40

The recent 1.2.0 version has a bunch of issues and here is my fix: 1. It requires 1.2.0 version of maestral-qt, which hasn't arrived AUR yet. But we just rebuild the package and it will retrieve the latest 1.2.0 GUI.

  1. It requires dropbox 1.4.0 but at least on Manjaro (I am using), it is still on 10.3.1, changing the version in requires.txt (/usr/lib/python3.8/site-packages/maestral-1.2.0-py3.8.egg-info/requires.txt) works.

  2. The new version requires sqlalchemy but for some reason paman-gtk didn't asks for it, I need to install it manually.

After all those changes, it runs without any issue (if there's any, I will update).

[edited for formatting]

coxackie commented on 2020-06-16 10:44

Peculiar - I am not getting this error. Of course, I have not done a clean install. Not sure what can be the fault. I will follow the github issue.

bbaserdem commented on 2020-06-15 18:46

I added a release package for python-bugsnag.

I'm getting a importlib.metadata.PackageNotFoundError: maestral==1.1.0 error constantly. I'll also post on github.