Package Details: machinarium 3-14

Git Clone URL: https://aur.archlinux.org/machinarium.git (read-only, click to copy)
Package Base: machinarium
Description: A point-and-click logic adventure game by the creators of Samorost (requires copy of the full game)
Upstream URL: http://machinarium.net/
Keywords: 2d adventure game humble point-and-click puzzle robot
Licenses: unknown
Submitter: Svenstaro
Maintainer: Rhinoceros
Last Packager: Rhinoceros
Votes: 48
Popularity: 0.000000
First Submitted: 2009-12-24 06:01
Last Updated: 2018-06-04 11:15

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Synthead commented on 2012-06-04 06:10

This seems to launch an empty Flash window.

alexiobash commented on 2012-05-23 09:20

solved! thank you very much

mmm commented on 2012-05-22 20:19

ale_xiovk, the PKGBUILD is accessible right from this site, so it looks as some local problem at your end. (the aur-helper, net connection?)

alexiobash commented on 2012-05-22 16:21

==> Downloading machinarium PKGBUILD from AUR...
==> ERROR: machinarium not found in AUR.

alexiobash commented on 2012-05-22 16:21

==> Downloading machinarium PKGBUILD from AUR...
==> ERROR: machinarium not found in AUR.

Neschur commented on 2011-11-02 19:21

May be be added on depending flashplayer-standalone and fix machinarium.sh:
cd "/usr/share/games/machinarium"
/usr/bin/flashplayer ./machinarium-browser.swf
And move from /usr/share/games/machinarium to /usr/share/machinarium?

unhammer commented on 2011-08-22 09:14

when I start the binary, I get this Adobe Flash Player browser, and have to click File->Open and select the swf. If I run it like "machinarium /usr/share/games/machinarium/machinarium-browser.swf", it starts right up though. Shouldn't the shell script have that path in there instead of "$@"?

Anonymous comment on 2011-08-21 19:33

I had a problem with the Machinarium binary not working after makepkg's symbol stripping (I have the Humble Indie Bundle version) while it worked fine after just unpacking the tarball (running "strip --strip-all" manually broke the binary again). Looks like this can be fixed by adding "options=(!strip)" to the PKGBUILD.

dobo commented on 2011-01-20 01:12

Actually we don't have to extract swf from windows binary. It's possible to extract it from linux elf. According to this post http://phoronix.com/forums/showthread.php?27775-The-Humble-Indie-Bundle-2-Has-Arrived&p=161829#post161829 we can do:
dd if=Machinarium of=Machinarium.swf ibs=1 skip=$(grep -abo FWS Machinarium|cut -f1 -d:|tail -1)
But i think it doesn't change anything in legal way.

kralyk commented on 2010-12-20 22:48

Thanks a lot, both machinarium and osmos now work fine for me ;-)