Package Details: m64py 0.2.4-4

Git Clone URL: https://aur.archlinux.org/m64py.git (read-only)
Package Base: m64py
Description: A Qt5 front-end (GUI) for Mupen64Plus, a cross-platform plugin-based Nintendo 64 emulator
Upstream URL: https://github.com/mupen64plus/mupen64plus-ui-python
Keywords: Emulator m64py nintendo64
Licenses: GPL
Submitter: TingPing
Maintainer: frealgagu
Last Packager: frealgagu
Votes: 91
Popularity: 0.304380
First Submitted: 2012-07-25 06:07
Last Updated: 2018-11-09 01:09

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Aerion commented on 2015-05-14 11:42

Python3 support doesn't appear to work. After installing python-qt5 the build still fails with the following python2 related errors:

==> Starting package()...
running install
running build
running build_qt
Traceback (most recent call last):
File "setup.py", line 380, in <module>
("share/applications", ["xdg/m64py.desktop"]),
File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
dist.run_commands()
File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
self.run_command(cmd)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "/usr/lib/python2.7/distutils/command/install.py", line 563, in run
self.run_command('build')
File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
self.distribution.run_command(command)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "setup.py", line 344, in run
self.run_command("build_qt")
File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
self.distribution.run_command(command)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "setup.py", line 65, in run
self.compile_rc(join(dirpath, filename))
File "setup.py", line 43, in compile_rc
import PyQt5
ImportError: No module named PyQt5
==> ERROR: A failure occurred in package().
Aborting...

Installing python2-qt5 allows the package to be built.

agapito commented on 2015-05-13 18:31

ChangeLog
Version 0.2.3

Migrated to Qt5
Python3 support
Toggle video extension without restart
Add windows portable build

Ryblade commented on 2015-05-13 13:56

I'm also getting the same error as agapito. Line for line.

franey: Do I need python2-pyqt5 just for building, or is this also a runtime dep? Just wondering if I should put it under "depends" or "makedepends" in the PKGBUILD.

Ryblade commented on 2015-05-13 13:52

I'm getting the same problem as agapito. Line for line.

franey commented on 2015-05-13 13:51

I can confirm the agapito's error. Installing 'python2-pyqt5' allowed m64py to build properly.

agapito commented on 2015-05-13 12:57

running install
running build
running build_qt
Traceback (most recent call last):
File "setup.py", line 380, in <module>
("share/applications", ["xdg/m64py.desktop"]),
File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
dist.run_commands()
File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
self.run_command(cmd)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "/usr/lib/python2.7/distutils/command/install.py", line 563, in run
self.run_command('build')
File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
self.distribution.run_command(command)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "setup.py", line 344, in run
self.run_command("build_qt")
File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
self.distribution.run_command(command)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "setup.py", line 65, in run
self.compile_rc(join(dirpath, filename))
File "setup.py", line 43, in compile_rc
import PyQt5
ImportError: No module named PyQt5

Sudowoodo commented on 2015-05-13 11:58

Updated to 0.2.3.

Sudowoodo commented on 2015-02-27 18:55

@gustawho
Upstream description is "a Qt4 front-end (GUI) for Mupen64Plus 2.0".
Why should I change it to Qt5? Also, there hasn't been a new release since 0.2.2, so I'm unflagging.

gustawho commented on 2015-02-17 06:45

Please, change "QT4" to "Qt5" in the description.

Sudowoodo commented on 2014-10-20 16:23

Updated to 0.2.2.