Package Details: m64p-git 20211203.r1.gfa29bc1-1

Git Clone URL: https://aur.archlinux.org/m64p-git.git (read-only, click to copy)
Package Base: m64p-git
Description: Mupen64Plus with custom plugins and Qt5 GUI (git version)
Upstream URL: https://m64p.github.io/
Keywords: emulator n64 nintendo64
Licenses: GPL3
Conflicts: m64p, mupen64plus, mupen64plus-gui, mupen64plus-video-gliden64
Provides: m64p, mupen64plus-gui, mupen64plus-video-gliden64
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 0
Popularity: 0.000000
First Submitted: 2020-04-10 21:01
Last Updated: 2021-12-05 17:32

Latest Comments

jt525 commented on 2021-12-01 00:05

That's great. It builds properly now. I've ran into another issue now: the core library (libmupen64plus.so.2) gets installed to /usr/lib and the plugins get installed to /usr/lib/mupen64plus but the program looks for both the library and the plugins in /usr/bin. I've worked around this by symlinking everything to where mupen64plus is looking for it in /usr/bin. I have tried the non-git version of this package and I have the same issue. Is this known behaviour or something misconfigured on my system?

dbermond commented on 2021-11-30 22:45

@jt525 Package updated to match the latest upstream changes.

jt525 commented on 2021-11-30 12:29

Build is failing at patching

patching file build.sh patching file build.sh patching file mupen64plus-gui/mainwindow.cpp Hunk #2 FAILED at 372. Hunk #3 succeeded at 431 (offset -8 lines). 1 out of 3 hunks FAILED -- saving rejects to file mupen64plus-gui/mainwindow.cpp.rej

The issue seems to be in 030-m64p-fix-paths.patch

dbermond commented on 2021-07-18 12:08

@spinvis Package updated to match the latest upstream changes. Building fine now.

spinvis commented on 2021-07-13 17:13

Build is failing as of recent;

patching file build.sh Hunk #1 FAILED at 24. Hunk #2 succeeded at 45 (offset 2 lines). Hunk #3 succeeded at 64 (offset 2 lines). 1 out of 3 hunks FAILED -- saving rejects to file build.sh.rej ==> ERROR: A failure occurred in prepare(). Aborting...

simer commented on 2020-05-25 15:19

One unfortunate side-effect of the new 'mupen64plus' addition to conflicts (but not provides) is that I can no longer install other plugins such as angrylion-plus or cxd4, which should work with m64py. In my case I hacked the PKGBUILD to add it to provides, but might be a better way that blocks incompatible front-ends from installing.

dbermond commented on 2020-05-25 15:09

@simer Working fine now. Fixed provides/conflicts, thanks.

simer commented on 2020-05-17 15:51

I had to update 010-m64p-git-remove-build-jobs-limitation patch to make it build due to some recent changes, see https://gist.github.com/sp1187/36a57ec78989a5800ff772e4b9bbef7a. Also the mupen64plus-video-gliden64 conflict is misspelled as "mupenplus-video-gliden64".