Package Details: lxqt-panel-git 0.13.0.1104.gc6f910fd-1

Git Clone URL: https://aur.archlinux.org/lxqt-panel-git.git (read-only, click to copy)
Package Base: lxqt-panel-git
Description: The LXQt desktop panel
Upstream URL: https://github.com/lxde/lxqt-panel
Licenses: GPL2
Conflicts: lxqt-panel
Provides: lxqt-panel
Submitter: jleclanche
Maintainer: pmattern
Last Packager: pmattern
Votes: 46
Popularity: 0.000000
First Submitted: 2013-10-24 01:13
Last Updated: 2018-12-15 22:21

Latest Comments

1 2 3 4 5 6 ... Next › Last »

yan12125 commented on 2020-01-04 11:19

@theriddick: I guess you're hit by a libqtxdg issue. I merged the upstream fix [1]. Could you upgrade libqtxdg-git and try again?

[1] https://github.com/lxqt/libqtxdg/pull/199

theriddick commented on 2020-01-04 10:39

Can't seem to build this, get make: *** [Makefile:130: all] Error 2 in a few spots randomly. Sometimes it gets to %94 built then errors out.

Also tried the direct GIT version and it does the same. First git that's ever done such a vague error out like this.

yan12125 commented on 2019-02-26 09:07

Hi, could you: move "libstatgrab" and "libsysstat-git" to optdepends instead of mandatory depends? This is what community/lxqt-panel does. use https://github.com/lxqt/lxqt-panel as the homepage and https://github.com/lxqt/lxqt-panel.git for the git URL.

yan12125 commented on 2017-11-25 17:00

Hello, could you add lxqt-build-tools-git to makedepends? (lxqt-build-tools doesn't work after https://github.com/lxde/lxqt-panel/pull/442)

yan12125 commented on 2016-11-10 15:14

Hi, could you remove kguiaddons from depends? See https://github.com/lxde/lxqt-panel/commit/3b9c7b9d5b07333047ca4620f8a441d0ec043771

yan12125 commented on 2016-09-25 14:05

Thanks @pmattern. My intuition is that all plugins will detect dependencies automatically. Anyway uniform behaviors among plugins is the way to go.

And congrats to version 0.11! I've switched back to prebuilt packages in [community].

pmattern commented on 2016-09-25 12:16

@jedr93
The version of AUR packages providing VCS checkouts is calculated at build time by function pkgver(). Thus it's common practice to update variable (!) pkgver only when there's a real reason which means there was no need to flag this package out-of-date.
You may e. g. have a look at lxqt-{about,sudo}-git. This even still stick with 0.9.x and rightly nobody cares.

pmattern commented on 2016-09-20 23:31

@yan12125
We've discussed the issue with libsysstat you pointed out and agreed to change the way lxqt-panel deals with dependencies.
Thanks again for the heads-up.

yan12125 commented on 2016-09-06 13:50

Thanks. Just disowned it.

pmattern commented on 2016-09-06 10:10

Confirmed.
When -DSYSSTAT_PLUGIN=No is removed and libsysstat is not available cmake simply fails. Expected behavior would be plugin-sysstat isn't built, the output of cmake is comprising a corresponding note but that aside building the panel succeeds. This is what happens with plugin-{networkmonitor,cpuload} and their dependency libstatgrab which should behave the same as plugin-sysstat vs. libsysstat.
So there seems indeed to be an issue we should have a look at upstream.

Nevertheless I'd be glad to maintain this package. I figure changes like new dependencies could make it into the package more quickly that way.