Package Details: lwks 14.5.0-1

Git Clone URL: https://aur.archlinux.org/lwks.git (read-only)
Package Base: lwks
Description: Lightworks is a professional video editing suite
Upstream URL: http://www.lwks.com/
Keywords: editor lightworks lwks video
Licenses: custom
Conflicts: lightworks, lwks-beta
Provides: lightworks
Submitter: CYB3R
Maintainer: marcinn
Last Packager: marcinn
Votes: 127
Popularity: 0.359509
First Submitted: 2013-01-30 14:17
Last Updated: 2018-10-18 12:04

Dependencies (18)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

marcinn commented on 2015-10-11 11:57

LWKS 12.5.0 (stable) is out. Can you update package?

marcinn commented on 2015-09-18 12:08

Audio continued... I've noticed some collision with other apps using audio (like chrome` video player). This is strange. It seems that lwks locks audio exclusively (???). Also I've tried `pulse` device instead of `sysdefault` - it works until other app is playing...

Has anyone got any solution?

marcinn commented on 2015-09-18 09:38

I can confirm missing audio with beta 12.5. But after a little investigation I've got sound working. To do that check `~/Lightworks/Logs/error.log`, find audio ports listed by PortAudio, remember # for device named `sysdefault`, and create `~/Lightworks/GlobalSettings.txt` file:

[PortAudio]
OutputDeviceIndex=<sysdefault device #>

derivator commented on 2015-07-12 11:57

Can confirm the workaround mentioned by CharlesAtum works on 12.0.2, using curl 7.41.0-1 (!) and openssl 1.0.1.l-1.

derivator commented on 2015-07-12 11:56

Can confirm the workaround mentioned by CharlesAtum works on 12.0.2, using 7.41.0-1 (!) and openssl 1.0.1.l-1.

Anonymous comment on 2015-07-05 16:40

For anyone having problems due to the openssl and curl lib versions and who doesn't want to downgrade system packages there's the workaround mentioned on http://dev.lwks.com/issues/397#note-2 of copying the needed lib versions from old packages into /usr/lib/lightworks.
If you don't have the packages on your cache then download from the Arch Rollback Machine. Copy the libssl.so* and libcurl.so* from the respectives /usr/lib directories of the .pkg.tar.xz.
I used curl 4.41.0-1 and openssl 1.0.1.l-1 and it worked for me on the beta version, it might work on the stable version as well.

Anonymous comment on 2015-07-02 12:53

Uploaded to AUR4 and updated with .SRCINFO for AUR3.

satriani commented on 2015-05-31 16:43

No sound with v.12.5.A/B/C

Anyone can confirm?

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

$ lsb_release -a
LSB Version: 1.4
Distributor ID: Arch
Description: Arch Linux
Release: rolling
Codename: n/a

+ OS: Arch Linux x86_64
# Hostname: MY-PC
### Kernel Release: 4.0.4-2-ARCH
##### Uptime: 9:28
###### WM: None
; #####; DE: GNOME
+##.##### Packages: 1203
+########## Processor Type: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
#############; $EDITOR: None
###############+ Root: 11G / 29G (37%) (ext4)
####### #######
.######; ;###;`".
.#######; ;#####.
#########. .########`
######' '######
;#### ####;
##' '##
#' `#

Cooldezz commented on 2015-03-08 23:08

Lightworks breaks due to the updated openssl. The error has been reported and forwarded to the dev team: http://dev.lwks.com/issues/397

A workaround is downgrading to an earlier version of openssl, with the lastest working release being 1.0.1.l.

Hopefully this will be fixed soon.

Keith_EE commented on 2015-03-04 17:03

I just tried what worked for MTB-BJJ but it did not work for me:

http://pastebin.com/HsFHR5nP