Package Details: luminancehdr-git 2.5.1.r245.g7dc448a6-1

Git Clone URL: https://aur.archlinux.org/luminancehdr-git.git (read-only, click to copy)
Package Base: luminancehdr-git
Description: Open source graphical user interface application that aims to provide a workflow for HDR imaging
Upstream URL: http://qtpfsgui.sourceforge.net/
Licenses: GPL
Conflicts: luminancehdr
Provides: luminancehdr
Submitter: spider-mario
Maintainer: spider-mario
Last Packager: spider-mario
Votes: 1
Popularity: 0.005600
First Submitted: 2018-09-03 18:20
Last Updated: 2020-11-13 21:42

Latest Comments

satcom886 commented on 2020-11-15 21:18

Thank you for fixing this, great job!

spider-mario commented on 2020-11-13 21:36

Ah, in this case, they are indeed at fault. I have patched the CMakeLists.txt to work around it. Thanks again for the report.

And yes, I learned it somewhat recently too. :)

satcom886 commented on 2020-11-12 17:51

Oh, I didn't know that! I'm learning more every day!

Problem is that the package doesn't build without is. That means the problem is probably in upstream's CMakeLists.txt, right?

CMake Error at CMakeLists.txt:8 (string):
  string no output variable specified


CMake Error at CMakeLists.txt:12 (message):
  Invalid value for CMAKE_BUILD_TYPE:

  CMAKE_BUILD_TYPE should be one of:

  Debug, Release, RelWithDebInfo, MinSizeRel


-- Configuring incomplete, errors occurred!

spider-mario commented on 2020-11-12 14:18

Thanks for the report. Such build-time-only dependencies are easy to miss, I’ll add it.

PKGBUILDs are not supposed to pass -DCMAKE_BUILD_TYPE=Release to CMake, though: https://wiki.archlinux.org/index.php/CMake_package_guidelines#CMake_undesired_behaviors

satcom886 commented on 2020-11-11 19:48

There are 2 issues with this package. Firstly CMake complains that the build type wasn't specified. This is easily fixed by adding -DCMAKE_BUILD_TYPE=Release to CMake's arguments. Secondly eigen is required to build this package.