Package Details: lua51-utf8 0.1.3-1

Git Clone URL: https://aur.archlinux.org/lua-utf8.git (read-only, click to copy)
Package Base: lua-utf8
Description: Add UTF-8 support to Lua, compatible with Lua string module
Upstream URL: https://github.com/starwing/luautf8
Licenses: MIT
Submitter: caleb
Maintainer: caleb (Xabre)
Last Packager: caleb
Votes: 4
Popularity: 0.018758
First Submitted: 2016-04-23 08:16
Last Updated: 2020-08-08 15:52

Dependencies (6)

Required by (2)

Sources (1)

Latest Comments

caleb commented on 2020-08-07 07:38

@Ekerim The lua53-* variant of packages in the AUR did not exist before yesterday, there is nothing to downgrade to. Before that the lua-* package names were the Lua 5.3 ones, because that was what the Arch [community] lua package was. The night before last they rolled out 5.4 as lua and moved the previous lua to lua53. The subpackages built by this and various other AUR packages had to be updated to match.

Because of the half backed way Arch decided to tackle this transition there isn't really a way to get old versions of some things and not others. Either you have to go back to defaulting to Lua 5.3 with old [community] packages and rebuild old versions of modules, or adapt to the new normal.

Ekerim commented on 2020-08-07 05:29

I'm probably doing something stupid as I'm not an experienced AUR user.
When I try to upgrade the package I get:

[user@host ~]$ pamac update
Preparing...
Cloning lua-utf8 build files...
Checking lua51-utf8 dependencies...
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: User Name (user)
Password: 
==== AUTHENTICATION COMPLETE ====
Synchronizing package databases...
Resolving dependencies...
Warning: cannot resolve "lua53", a dependency of "lua51-utf8"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'lua53' required by lua51-utf8

Pamac is unable to find the lua53 package.
I do have lua 5.3.5 installed from default repository.
What am I doing wrong here ?
Cheers.

caleb commented on 2020-05-05 14:38

@tyrannis.hawk and @8BitSloth My apologies, this actually appears to be a bug in makepkg but it can be mitigated as you suggest. Usually with package builds you do not need to duplicate dependencies in the makedepends that are already part of depends, it will infer then. Apparently that doesn't work right for subpackages that specify their own separate depends. Manually adding the makedepends to the pkgbase does help mitigate, so I'll do that.

tyrannis.hawk commented on 2020-05-05 14:07

It does fail to build in a clean build environment.

Warning: Lua 5.2 interpreter not found at /usr

Modules may not install with the correct configurations. You may want to specify the path prefix to your build of Lua 5.2 using --lua-dir

Error: Build error: Lua header file lua.h not found (looked in /usr/include/lua5.2).
You need to install the Lua development package for your system.

and

Warning: Lua 5.1 interpreter not found at /usr

Modules may not install with the correct configurations. You may want to specify the path prefix to your build of Lua 5.1 using --lua-dir
sh: /usr/bin/lua5.1: No such file or directory

Error: Build error: Lua header file lua.h not found (looked in /usr/include/lua5.1).
You need to install the Lua development package for your system.

This can be fixed by adding 'lua51' and 'lua52' to the makedepends. Could you please add these to your PKGBUILD?

caleb commented on 2020-05-03 16:12

@8BitSloth This package isn't out of date. The Lua52 dependency (and Lua51) are because this builds sub-packages for all three major versions of Lua. These are only all required at build time (makedepends). The build package for each version only requires its respective version of Lua.