Package Details: lua-luassert 1.8.0-4

Git Clone URL: https://aur.archlinux.org/lua-luassert.git (read-only, click to copy)
Package Base: lua-luassert
Description: Lua Assertions Extension
Upstream URL: https://olivinelabs.com/busted/
Licenses: MIT
Submitter: caleb
Maintainer: caleb (SolarAquarion)
Last Packager: caleb
Votes: 10
Popularity: 0.34
First Submitted: 2019-06-18 13:14
Last Updated: 2020-02-24 05:02

Dependencies (3)

Required by (1)

Sources (1)

Pinned Comments

caleb commented on 2020-02-21 11:50

PSA: I've started hosting this, all its dependencies, and also many other Lua Rocks as prebuilt packages in my repository for those that want to install them using pacman without messing around with building from the AUR.

Latest Comments

caleb commented on 2020-02-21 11:50

PSA: I've started hosting this, all its dependencies, and also many other Lua Rocks as prebuilt packages in my repository for those that want to install them using pacman without messing around with building from the AUR.

caleb commented on 2020-02-06 05:40

Hey I am the maintainer of the lua-luassert base package with provides Lua 5.3 and 5.2 packaging for this. I think it would make a lot more sense if this package were deleted and that package could add 5.1 packaging as well. I have already added you @SolarAquarion as a co-maintainer over there and the packaging is ready to go, but I can't add 5.1 to the list until this is out of the way in the AUR. Would you be willing to join forces there so this can be cleaned up and maintained in one place?

pablo-vs commented on 2019-03-07 11:48

luarocks5.1 has been replaced by luarocks

aidanholm commented on 2018-01-17 18:37

/usr/bin/luacheck contains references to $pkgdir, so it can't be used from the command line

t0m5k1 commented on 2017-10-29 10:16

Unable to build:
:: Building lua51-say package(s)...
==> Making package: lua51-say 1.3-1 (Sat 28 Oct 18:15:45 BST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...
Warning: skipping dependency checks.

Error: Error fetching file: Failed downloading https://github.com/Olivine-Labs/say/archive/v1.3-1.tar.gz - v1.3-1.tar.gz
==> ERROR: A failure occurred in package().
Aborting...
:: Building lua51-luassert package(s)...
==> Making package: lua51-luassert 1.7.10-2 (Sat 28 Oct 18:15:46 BST 2017)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: lua51-say
==> ERROR: 'pacman' failed to install missing dependencies.