Package Details: lsyncd 2.2.3-3

Git Clone URL: https://aur.archlinux.org/lsyncd.git (read-only, click to copy)
Package Base: lsyncd
Description: Live Syncing (Mirror) Daemon
Upstream URL: https://github.com/axkibe/lsyncd
Licenses: GPL2
Submitter: djgera
Maintainer: Thermi
Last Packager: Thermi
Votes: 63
Popularity: 0.169703
First Submitted: 2009-03-25 20:03
Last Updated: 2020-09-12 13:02

Latest Comments

1 2 3 4 5 Next › Last »

Thermi commented on 2020-09-18 15:54

I'll add a workaround/fix once one becomes available. I myself don't use lsyncd anymore, so it's not a priority.

bighead commented on 2020-09-17 14:10

I removed lua53 and lua52 (losing VLC and GIMP as they had to go along with them), reinstalled lsyncd and now it works. Not optimal but I need lsyncd more than those two. Thanks njam for the tip.

njam commented on 2020-09-17 13:03

I experience the same error ("bad binary format (version mismatch)").

Maybe caused by different lua versions installed (package "lua" (5.4), "lua53" (5.3) and "lua52" (5.2)), and then lsyncd picking the wrong one? See also https://github.com/axkibe/lsyncd/issues/413

bighead commented on 2020-09-16 14:40

I get this error after last update: error loading precompiled runner: runner: bad binary format (version mismatch) Any ideas?

Thermi commented on 2020-09-12 13:04

Thank you for your work, I incorporated the changes made by wwwlea into the sources here.

luizribeiro commented on 2020-09-06 14:01

@wwwlea's patch worked perfectly for me. @Thermi, can you update the package so that it includes his patches?

wwwlea commented on 2020-08-26 08:30

I had some errors building with the newest version of Lua (5.4) that was released earlier this month. I resolved these with two changes:

  • A macro in lsyncd.h needs to be renamed from from "LUA_COMPAT_5_1" to "LUA_COMPAT_5_3"

  • The "FindLua.cmake.patch" needs to be updated so that it also finds version 5.4 and not just 5.3 and 5.2

I have put these changes on GitHub at https://github.com/HippocampusGirl/lsyncd-aur

klemens commented on 2020-08-18 21:36

I think this should now depend on lua53 instead of lua.

vamega commented on 2018-07-28 05:22

I updated the PKGBUILD and made a patch to have this build against lua5.3. Upstream prefers Lua5.2 because Debian doesn't have some lua libraries for 5.3 packaged.

Would you consider incorporating the latest commit from https://github.com/vamega/lsyncd-aur/ into this package.

neonardo commented on 2018-06-12 15:29

@Noeljunior it will build against lua 5.3 now. I was having trouble getting a working binary so I removed the 5.2 libs so it would stop building against them, modified pkgbuild so it would not require them, and it built successfully against 5.3.

As of lsyncd 2.2.3 it's supposed to be compatible with lua 5.3 moving forward so perhaps it's time to get this package updated to reflect that, and use it.

Good luck.