Package Details: lsd-git 0.16.0.471.gad25edc-2

Git Clone URL: https://aur.archlinux.org/lsd-git.git (read-only, click to copy)
Package Base: lsd-git
Description: The next gen ls command
Upstream URL: https://github.com/Peltoche/lsd
Licenses: Apache
Conflicts: lsd
Provides: lsd
Submitter: Peltoche
Maintainer: jeffw
Last Packager: jeffw
Votes: 3
Popularity: 0.013801
First Submitted: 2018-11-25 13:08
Last Updated: 2020-02-23 21:57

Latest Comments

jeffw commented on 2020-04-11 03:15

This is a git package and just pulls from the default branch (master). It cannot be out of date as far as I can tell. I'm not sure how to handle the version field in the PKGBUILD, but it is not accurate.

anodium commented on 2019-08-22 07:13

@Peltoche The package is completely broken and will not build. I've rewritten it so that it does, while complying with the Rust packaging guidelines, the VCS packaging guidelines, and keeping namcap happy.

I've uploaded the patch to a Gist, which you can apply with git am 0001-Fix-package.patch.

PS: I also removed nerd-fonts-complete from the dependencies. Despite support for Font Awesome or Nerd Fonts being a hard dependency for lsd, there are a lot more packages besides nerd-fonts-complete that provide that, but none of them have a common provides array set. (I'm personally using ttf-fira-code with ttf-nerd-fonts-symbols ^_^)

aether commented on 2019-05-01 14:49

==> Checking for packaging issues... ==> ERROR: Dotfile found in package root '/home/richard/git/lsd-git/pkg/lsd-git/.crates.toml'