Package Details: lone_wolf-clang-git 9.0.0_r316130.bd588dfd594-1

Git Clone URL: https://aur.archlinux.org/lone_wolf-clang-git.git (read-only)
Package Base: lone_wolf-clang-git
Description: C language family frontend for LLVM
Upstream URL: https://clang.llvm.org/
Licenses: custom:University of Illinois/NCSA Open Source License
Conflicts: clang
Provides: clang=9.0.0_r316130.bd588dfd594-1
Submitter: Lone_Wolf
Maintainer: Lone_Wolf
Last Packager: Lone_Wolf
Votes: 1
Popularity: 0.374051
First Submitted: 2019-05-04 15:45
Last Updated: 2019-05-09 23:33

Required by (401)

Sources (2)

Pinned Comments

Lone_Wolf commented on 2019-05-17 22:12

This package is now obsolete, switch to clang-minimal-git instead.

Latest Comments

Lone_Wolf commented on 2019-05-17 22:12

This package is now obsolete, switch to clang-minimal-git instead.

cogwerkz commented on 2019-05-05 09:23

Thank you! Adding the path to the correct python exectubable appears to have done the trick. It reached the check(), and appears to be running fine without bugs now.

If something else pops up, I know where to look now. I'll let you know when it's done if it went smoothly or if I had to use some other workarounds.

Lone_Wolf commented on 2019-05-05 08:01

-DPYTHON_EXECUTABLE=/usr/bin/python \

try adding that line to the cmake command in build() , just below the

-DCMAKE_INSTALL_PREFIX=/usr \ line.

You will get another error in check(), but that's related to risc64 arch.

Lone_Wolf commented on 2019-05-05 07:46

cd /home/lars/.cache/yay/lone_wolf-clang-git/src/_build/test &&
/usr/bin/python2.7 /usr/bin/lit -sv --param

The package is supposed to be built with python3, let me check if there's a way to ensure that.

cogwerkz commented on 2019-05-05 07:33

I'm sorry if this is a mega noobish question, but if so that's just because I'm a mega noob.

My compilation fails, and I'm not strictly certain why. I've build and installed lone_wolf-llvm-libs-git, lone_wolf-llvm-git, lone_wolf-ocaml-git, lone_wolf-compiler-rt-git, but it now fails on lone_wolf-clang-git, this.

My goal is ofc to build your mesa-git packages here, and thought I'd start by building all your versions of the dependencies first, since experience tells me that using other versions tend to make other problems pop up somewhere down the road. But my noobishness is shining through, because I'm stuck here!

It fails right when it reaches check(). Am I missing a package, do I have the wrong version of something? What obvious thing am I doing wrong here? :o

Edit: I'm using the 4.19.31-rt18-1-rt-lts kernel, if that's of any consequence here.

Error message when it fails:

==> Starting check()... [0/2] Running the Clang regression tests Traceback (most recent call last): File "/usr/bin/lit", line 6, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources FAILED: test/CMakeFiles/check-clang cd /home/lars/.cache/yay/lone_wolf-clang-git/src/_build/test && /usr/bin/python2.7 /usr/bin/lit -sv --param clang_site_config=/home/lars/.cache/yay/lone_wolf-clang-git/src/_build/test/lit.site.cfg --param USE_Z3_SOLVER=0 /home/lars/.cache/yay/lone_wolf-clang-git/src/_build/test ninja: build stopped: subcommand failed. ==> ERROR: A failure occurred in check(). Aborting... Error making: lone_wolf-clang-git