Package Details: lollypop-next-git 1.4.2.r5.gff2228bc-1

Git Clone URL: https://aur.archlinux.org/lollypop-next-git.git (read-only, click to copy)
Package Base: lollypop-next-git
Description: Music player for GNOME (dev branch)
Upstream URL: https://gitlab.gnome.org/gnumdk/lollypop
Licenses: GPL
Conflicts: lollypop, lollypop-git, lollypop-stable-git
Provides: lollypop
Submitter: gnumdk
Maintainer: gnumdk
Last Packager: gnumdk
Votes: 20
Popularity: 0.008324
First Submitted: 2020-02-26 13:27
Last Updated: 2020-10-13 08:00

Required by (1)

Sources (1)

Latest Comments

1 2 3 4 Next › Last »

gnumdk commented on 2020-02-25 20:47

Hello, can you remove this package, it does not make sense anymore: https://aur.archlinux.org/packages/lollypop-next (current dev branch)

and I'm going to add lollypop-stable (stable release + last fixes)

phw commented on 2018-01-31 07:49

The git package is missing from makedepends. This causes the package not to be buildable in a chroot

0x647262 commented on 2018-01-03 01:42

@manawyddan,

Could you walk me through the steps you took to build the application? I'm unable to reproduce this on either of my systems.

manawyddan commented on 2017-12-16 19:51

Permission denied when trying to run freshly built lollypop:

% lollypop
/usr/lib/python3.6/site-packages/gi/module.py:176: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:176: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:176: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
Database::__init__(): g-io-error-quark: Error creating directory /usr/lib/lollypop: Permission denied (14)

0x647262 commented on 2017-12-13 02:05

Sources changed.

I'll push an updated PKGBUILD shortly!

gatlinnewhouse commented on 2017-12-13 00:16

Error during installation:

==> Making package: lollypop-git 0.9.244.r67.ga77dff23-1 (Tue Dec 12 16:19:22 PST 2017)
==> Retrieving sources...
  -> Updating lollypop git repo...
Fetching origin
  -> Updating lollypop-help git repo...
Fetching origin
  -> Updating lollypop-po git repo...
Fetching origin
  -> Updating lollypop-portal git repo...
Fetching origin
==> Validating source files with sha256sums...
    lollypop ... Skipped
    lollypop-help ... Skipped
    lollypop-po ... Skipped
    lollypop-portal ... Skipped
:: Building lollypop-git package(s)...
==> Making package: lollypop-git 0.9.244.r67.ga77dff23-1 (Tue Dec 12 16:19:24 PST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Updated version: lollypop-git 0.9.304.r35.g9a49cdcb-1
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Error during basic setup:

Neither directory contains a build file meson.build.
==> ERROR: A failure occurred in build().
    Aborting...
:: failed to build lollypop-git package(s)

FredBezies commented on 2017-07-05 15:14

PKGBUILD updated.

bil-elmoussaoui commented on 2017-07-05 13:53

The master branch now uses meson instead of autotools:
the autotools deps should be replaced with
- meson
- ninja
- appstream-glib

FredBezies commented on 2017-04-21 05:33

@Pointedstick : thanks for the info. PKGBUILD adapted :)

Pointedstick commented on 2017-04-21 04:37

There are additional optional dependencies:

lollypop-portal easytag kid3-cli