Package Details: lollypop-git 0.9.244.r67.ga77dff23-1

Git Clone URL: https://aur.archlinux.org/lollypop-git.git (read-only)
Package Base: lollypop-git
Description: Lollypop is a new GNOME music playing application.
Upstream URL: https://gnumdk.github.io/lollypop-web/
Keywords: gnome last.fm music player
Licenses: GPL3
Conflicts: lollypop
Provides: lollypop
Submitter: brunelli
Maintainer: krakn
Last Packager: krakn
Votes: 18
Popularity: 0.884979
First Submitted: 2014-10-15 19:04
Last Updated: 2017-09-14 14:51

Latest Comments

FredBezies commented on 2017-07-05 15:14

PKGBUILD updated.

bil-elmoussaoui commented on 2017-07-05 13:53

The master branch now uses meson instead of autotools:
the autotools deps should be replaced with
- meson
- ninja
- appstream-glib

FredBezies commented on 2017-04-21 05:33

@Pointedstick : thanks for the info. PKGBUILD adapted :)

Pointedstick commented on 2017-04-21 04:37

There are additional optional dependencies:

lollypop-portal easytag kid3-cli

bmbaker commented on 2017-04-18 11:13

keeps crashing!

~ $ lollypop
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
g_type = info.get_g_type()

(lollypop:20178): GLib-GIO-ERROR **: Settings schema 'org.gnome.Lollypop' does not contain a key named 'music-uris'
Trace/breakpoint trap (core dumped)

DeathKhan commented on 2017-02-01 03:31

Now crashes
since latest update

gnumdk commented on 2016-12-19 13:31

Lollypop depends on https://github.com/gnumdk/lollypop-portal

It's optional.

FredBezies commented on 2016-12-09 18:36

@gnumdk : fixed :)

gnumdk commented on 2016-12-09 08:53

/usr/share/lollypop/lollypop-sp needs to be +x

gnumdk commented on 2016-10-25 15:19

Lollypop doesn't depend explicitly on pylast...

FredBezies commented on 2016-10-06 06:13

@archdria : fixed. Thanks.

arrufat commented on 2016-10-05 17:16

@FredBezies yes, I meant python-pylast, sorry.
But it's no longer optional...

FredBezies commented on 2016-10-05 05:45

@ærchdria : is python-pylast not enough ?

arrufat commented on 2016-10-04 11:39

It now depends explicitly on python-lastfm.

FredBezies commented on 2016-09-28 08:01

@Terence : Lollypop is gstreamer 1.x based. Gst-fluendo-mp3 is 0.10.x based, so not used at all here.

https://github.com/gnumdk/lollypop

"Depends on

gtk3 >= 3.14
gobject-introspection
gir1.2-gstreamer-1.0 (Debian)"

And if you look at https://packages.debian.org/jessie/gir1.2-gstreamer-1.0

dep: libgstreamer1.0-0 (>= 1.4.0)

If you want mp3 support, the working option is to use gst-plugins-bad package.

Terence commented on 2016-09-20 22:17

Please add gst-fluendo-mp3 (AUR) as an optional dependency.

bitseater commented on 2016-07-08 19:10

In fact, according to the developer, it seems it's out of date:

https://plus.google.com/109637860626261571611/posts/RBJ5xfjPFXG

rob2uk commented on 2016-07-07 22:57

Please refrain from marking packages as 'out of date' if they are not, in fact, out of date. Thanks.

yoseforb commented on 2015-06-16 12:34

Please, added python-wikipedia as depends.

brunelli commented on 2015-05-25 15:39

@yoseforb: I'm adding it as an optional dependency.

yoseforb commented on 2015-05-25 06:25

Please, added 'python-pylast' as a depends.

kitaro commented on 2015-05-15 23:40

@ianbrunelli

thanks for your concern. i solved it by removing the contents of my Music directory.

it's strange, i don't know why it failed to load.

brunelli commented on 2015-05-12 17:17

@kitaro:

> tried building from git source manually, the problem still occurs.

Well, then you should try opening an issue upstream, not here.

I've just installed here and it's working perfectly, but if you still can't launch it, open an issue here: https://github.com/gnumdk/lollypop

kitaro commented on 2015-05-12 12:52

lollypop crashed upon launching, forced to close.

Unhandled exception in thread started by <bound method CollectionScanner._scan of <CollectionScanner object at 0x7f4a10c46ab0 (lollypop+collectionscanner+CollectionScanner at 0x7f4a2808f5a0)>>
Traceback (most recent call last):
File "/usr/local/lib/python3.4/site-packages/lollypop/collectionscanner.py", line 207, in _scan
(new_tracks, new_dirs, count) = self._get_objects_for_paths(paths)
File "/usr/local/lib/python3.4/site-packages/lollypop/collectionscanner.py", line 112, in _get_objects_for_paths
f = Gio.File.new_for_path(filepath)
UnicodeEncodeError: 'utf-8' codec can't encode character '\udca4' in position 33: surrogates not allowed
Exception ignored in: <module 'threading' from '/usr/lib/python3.4/threading.py'>
Traceback (most recent call last):
File "/usr/lib/python3.4/threading.py", line 1296, in _shutdown
_main_thread._delete()
File "/usr/lib/python3.4/threading.py", line 1019, in _delete
del _active[get_ident()]
KeyError: 139955938522880

tried building from git source manually, the problem still occurs.

gnumdk commented on 2015-03-27 12:17

Missing deps:
- totem-plparser
- gobject-introspection

brunelli commented on 2015-03-25 14:45

@gnumdk Just updated the PKGBUILD :)

gnumdk commented on 2015-03-25 14:17

You can remove mutagen from deps, not needed anymore...

brunelli commented on 2014-10-27 16:23

If updating and the program fails to open, please remove the file $HOME/.local/share/lollypop/lollypop.db and try to open the program again.

brunelli commented on 2014-10-20 18:04

@FredBezies Done. Thanks for the tip!

FredBezies commented on 2014-10-16 21:13

Please add gnome-common to makedepends

"which: no gnome-autogen.sh in (/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
You need to install gnome-common from GNOME Git (or from
your OS vendor's package manager)."