Package Details: logmein-hamachi 2.1.0.203-1

Git Clone URL: https://aur.archlinux.org/logmein-hamachi.git (read-only, click to copy)
Package Base: logmein-hamachi
Description: A zero-configuration VPN service
Upstream URL: https://www.vpn.net/linux
Licenses: custom
Conflicts: hamachi
Replaces: hamachi
Submitter: Xavion
Maintainer: Vitruvius
Last Packager: Vitruvius
Votes: 226
Popularity: 0.99
First Submitted: 2010-07-10 01:04
Last Updated: 2019-08-21 23:38

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

RazZziel commented on 2017-09-12 06:05

Worked around the issue for now by downloading glibc-2.25 and running hamachid with it:

wget https://archive.archlinux.org/packages/g/glibc/glibc-2.25-7-x86_64.pkg.tar.xz
mkdir glibc-2.25-7-x86_64
cd glibc-2.25-7-x86_64
tar -xf ../glibc-2.25-7-x86_64.pkg.tar.xz
sudo LD_LIBRARY_PATH=$PWD/usr/lib/ usr/lib/ld-2.25.so /opt/logmein-hamachi/bin/hamachid debug

With that the hamachid daemon runs fine, and then I can run the hamachi client normally (with glibc 2.26)

RazZziel commented on 2017-09-12 04:48

This package is broken since the upgrade from glibc 2.25-7 to 2.26-3:

06:46:14 ~$ sudo /opt/logmein-hamachi/bin/hamachid debug
09.12 06:46:53.934 cfg: load()
09.12 06:46:53.934 dbg: deploy_id '' parse failed
09.12 06:46:53.934 cfg: hkc set: [2048] [2048]
09.12 06:46:53.934 cfg: save()
(...)
09.12 06:46:54.477 ses: resolving hamachi-list.5.logmein-gateway.com ..
hamachid: relocation error: hamachid: symbol __res_maybe_init, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

RazZziel commented on 2017-01-16 08:25

Hamachi 2.1.0.174-1 is available at https://www.vpn.net/linux

aeiou commented on 2016-01-18 14:08

I installed this, and when I run `hamachi`, it says `Run '/etc/init.d/logmein-hamachi start' to start daemon.` but /etc/init.d doesn't exist.

EDIT: Just run `systemctl enable logmein-hamachi.service`

Xavion commented on 2015-09-07 07:35

Sorry, I'm not having that problem here. LogMeIn-Hamachi starts on boot without prompting for a password. I last upgraded my system packages two days ago.

PhotonX commented on 2015-09-07 06:44

Following problem: https://bbs.archlinux.org/viewtopic.php?id=201861 Reinstalling didn't help.

Xavion commented on 2014-08-16 06:29

Thanks for letting me know about that problem. The 'systemd' file was missing because the ultra-tight "mkaurball" script - that packagers are now forced to use - omits anything not listed in the "source=()" array. I've fixed the problem and uploaded the resultant PKGBUILD.

Zeben commented on 2014-08-15 23:13

I have a troubles with building Hamachi with this new PKGBUILD:
http://bpaste.net/show/lbRLyu9HFfVus22LAMxv/
What can I do to solve this?

Xavion commented on 2014-06-01 00:12

You'll need to create the "/var/lib/logmein-hamachi/h2-engine-override.cfg" file manually. Then, restart the LMI Hamachi daemon via "sudo systemctl restart logmein-hamachi.service".

inukaze commented on 2014-05-31 21:23

How i can fix the follow ? :

$ hamachi
You do not have permission to control the hamachid daemon.
You can run 'hamachi' as root, or you can add your login name to the file
'/var/lib/logmein-hamachi/h2-engine-override.cfg'
and restart the daemon with
sudo /etc/init.d/logmein-hamachi restart
Example:
Ipc.User <login name>

because the files
/var/lib/logmein-hamachi/h2-engine-override.cfg
/etc/init.d/logmein-hamachi restart

dont exist in ArchLinux x86_64