Package Details: logitechmediaserver-git 20190422.91bab34-1

Git Clone URL: https://aur.archlinux.org/logitechmediaserver-git.git (read-only, click to copy)
Package Base: logitechmediaserver-git
Description: Slimserver for Logitech Squeezebox players. This server is also called Logitech Media Server. (Git-Version, if you prefer stability consider using logitechmediaserver instead)
Upstream URL: https://github.com/stefansielaff/slimserver
Keywords: logitech slimserver squeezebox
Licenses: GPL, custom
Provides: logitechmediaserver
Submitter: stef.an
Maintainer: stef.an
Last Packager: stef.an
Votes: 8
Popularity: 0.000000
First Submitted: 2015-05-16 16:04
Last Updated: 2019-04-22 14:29

Required by (1)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

stef.an commented on 2015-07-04 09:56

Here we go, the main problem was the CPAN module "version" which is delivered with slimserver. Updated build script and some fixes on the included modules.

CGI::Cookie isn't available in perl core anymore and so on. I've decided to slowly move over to the arch provided libs. Therefore perl-cgi as new dependency, more to come.

If you're brave, feel free to test this. I'm running it on armv5 now, compiles and starts fine on my x64 VM but not further testet.
To make things simple: uninstall first, do the perl upgrade and run the makepkg afterwards, so you don't have to recompile everythin after the upgrade.

RadioGnome1971 commented on 2015-07-01 17:53

Keep up the good work! Lets all wait (edit /etc/pacman.conf and set IgnorePkg = perl and whatever depends on perl... perl-dbd-pg perl-dbi in my case)

Unfortunately my knowledge of perl is totally zero, so I depend on others to solve the issues.

stef.an commented on 2015-06-30 14:17

I understand that people have problems with the perl dependency (<5.21). Flagging the package out of date and so on.
But it's that simple - slimserver isn't compatible with perl 5.22 (yet).
I'm trying it on my machine but for now it doesn't work... so until this is solved we all can install perl 5.22 OR logitechmediaserver but unfortunately not both.

stef.an commented on 2015-06-29 15:27

I'm currently updating my system to check if it works with 5.22.
The precompiled modules are removed in the PKGBUILD so I'm cautiously optimistic an I'll remove the dependency asap!

happyarchlinuser commented on 2015-06-29 09:00

After the last update of the whole system the package logitechmediaserver-git does not work any more, the error message states that it requires perl <5.21. Current installed Perl version is 5.22. What now?

Anakon commented on 2015-06-26 14:25

Parsing the 'Revision' string is not portable across different locales. For example in my locale it doesn't work, because the output of svn info looks like:
...
UUID du dépôt : 43ee603d-f14b-27af-f68a-ce57b7db7bff
Révision : 21360
Type de nœud : répertoire
...

stef.an commented on 2015-05-18 19:41

Do you mean which as make depency?
I've just checked "which" and it is part of the base-devel group of which I think I've read it shouldn't be included.

jgl commented on 2015-05-18 17:37

Super!
Everything ok here only missing which as dependency

stef.an commented on 2015-05-17 17:20

Cool!
I've just uploaded rel2.
I've forked the repo on GitHub. rel1 did a checkout of all sources and removed everything not needed afterwards. So the download size was about 1GiB...

This version does an export of the already stripped sources. Saves 90% of size.

Renophaston commented on 2015-05-16 19:37

Everything I've tested so far has worked here on i686, which is awesome. Thanks for putting the work in!