Package Details: logitechmediaserver-git 20190422.91bab34-1

Git Clone URL: https://aur.archlinux.org/logitechmediaserver-git.git (read-only, click to copy)
Package Base: logitechmediaserver-git
Description: Slimserver for Logitech Squeezebox players. This server is also called Logitech Media Server. (Git-Version, if you prefer stability consider using logitechmediaserver instead)
Upstream URL: https://github.com/stefansielaff/slimserver
Keywords: logitech slimserver squeezebox
Licenses: GPL, custom
Provides: logitechmediaserver
Submitter: stef.an
Maintainer: stef.an
Last Packager: stef.an
Votes: 8
Popularity: 0.000000
First Submitted: 2015-05-16 16:04
Last Updated: 2019-04-22 14:29

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

stef.an commented on 2015-07-26 10:22

The vendor script already builds Template 2.21, could you check /opt/logitechmediaserver/CPAN/auto/Template/Stash/XS for XS.so?

fragfutter commented on 2015-07-26 08:47

web interface won't work.

Couldn't load Template::Stash::XS 2.21:


so installed perl-template-toolkit (should be a dependency)

still no luck, as perl-template-toolkit is version 2.26.

need to either compile toolkit with the logitechmediaserver or use a newer version.

stef.an commented on 2015-07-09 19:41

Hi boomshalek,
this is not a problem with this package but with your perl installation. You could try to remove (pacman -R perl-scalar-list-utils) if it's present. It's provided by perl-core since 5.22.
Btw. you don't have to use this Version, the "normal" Version is also compatible meanwhile.
Please report back if this helps you out, this might be interesting for others.

boomshalek commented on 2015-07-09 16:06



Hi
I wanted to update from standard (non-git) package to this due to the perl incompatibility.
But I get:
Exported revision 21376.
==> Sources fetched or server timeout
==> Starting build()...
RUN_TESTS:0 CLEAN:1 USE_HINTS:1 target all
Building for Linux / x86_64-linux-thread-multi
Building with Perl 5.22 at /usr/bin/perl
build_module run tests:0 clean:1 hints 1 Sub-Uplevel-0.22
tar zxvf Sub-Uplevel-0.22.tar.gz
tar done
‘../hints’ -> ‘./hints’
‘../hints/darwin.pl’ -> ‘./hints/darwin.pl’
Checking if your kit is complete...
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/auto/List/Util/Util.so: undefined symbol: Perl_xs_apiversion_bootcheck
make: *** No targets specified and no makefile found. Stop.
make failed, aborting
==> Entering fakeroot environment...
==> Starting package()...
cp: cannot stat ‘CPAN/build/5.*/lib/*/*linux*/*’: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

boomshalek commented on 2015-07-09 16:05

Hi
I wanted to update from standard (non-git) package to this due to the perl incompatibility.
But I get:
Exported revision 21376.
==> Sources fetched or server timeout
==> Starting build()...
RUN_TESTS:0 CLEAN:1 USE_HINTS:1 target all
Building for Linux / x86_64-linux-thread-multi
Building with Perl 5.22 at /usr/bin/perl
build_module run tests:0 clean:1 hints 1 Sub-Uplevel-0.22
tar zxvf Sub-Uplevel-0.22.tar.gz
tar done
‘../hints’ -> ‘./hints’
‘../hints/darwin.pl’ -> ‘./hints/darwin.pl’
Checking if your kit is complete...
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/auto/List/Util/Util.so: undefined symbol: Perl_xs_apiversion_bootcheck
make: *** No targets specified and no makefile found. Stop.
make failed, aborting

RadioGnome1971 commented on 2015-07-08 20:40

I translated the Dutch message 'Toegang geweigerd' to Access denied, but permission denied might be the propper translation.

I increased the size of the partition I use for building, retried, still the same.

icu4c-4_6-src.tgz has size 15543712 (15M)
the folder icu contains approx 70M (> du -sh icu)

runConfigureICU is located in src/slimserver-vendor/CPAN/icu/source/ (and not src/slimserver-vendor/CPAN/icu)
It is approx 11K and despite having rwxr-x-rx as permissions, I can't execute it, nor can root. aha.....

Moving the folder to a different partition made it executable. I have something to fix here and not in your package.
For now I consider this not an issue of logitechmediaserver-git.

Thanks for your help.

stef.an commented on 2015-07-08 19:32

Mhhh, sounds... weird!
Just building on one of my Pi's (gen 1 model B). Everything's good.
runConfigureICU shoud be located in slimserver-vendor/CPAN/icu - could you check again if it's there and of which size it is? Is the Pi overclocked? I think it might be a problem writing to the SD-Card as "Access denied" (instead of permiison denied) is unfamiliar. Usually this means the SD-Cards filesystem is f*cked up.

Here's my output:

tar zxvf icu4c-4_6-src.tgz
tar done
export CPP= CC=gcc CXX=g++ CPPFLAGS= CFLAGS=-fPIC -DU_USING_ICU_NAMESPACE=0 -O3 CXXFLAGS=-fPIC -DU_USING_ICU_NAMESPACE=0 -O3 LDFLAGS=-fPIC MAKE=/usr/bin/make
Running ./configure --prefix=/home/build/slimserver-vendor/CPAN/build --enable-static --with-data-packaging=archive for Linux using the GNU C++ compiler
...

RadioGnome1971 commented on 2015-07-08 18:10

Building fails at

tar zxvf icu4c-4_6-src.tgz
tar done
buildme.sh line 542: ./runConfigureICU: Access denied
.....
make failed..

./src/slimserver-vendor/CPAN/ does not contain ./runConfigureICU (but does contain icu4c-4_6-src.tgz)

Building on armv6h (R-Pi model B)

Kind regards,

Martin

RadioGnome1971 commented on 2015-07-08 17:46

Forgot.. building on armv6 (R-Pi model B)

RadioGnome1971 commented on 2015-07-08 17:39

Building fails at

tar zxvf icu4c-4_6-src.tgz
tar done
buildme.sh line 542: ./runConfigureICU: Access denied
.....
make failed..

./src/slimserver-vendor/CPAN/ does not contain ./runConfigureICU (but does contain icu4c-4_6-src.tgz)

Kind regards,

Martin