Package Details: lmod 8.5.16-1

Git Clone URL: https://aur.archlinux.org/lmod.git (read-only, click to copy)
Package Base: lmod
Description: Environment modules system based on Lua that handles MODULEPATH hierarchical problem. Supports also legacy TCL modules
Upstream URL: https://github.com/TACC/Lmod
Licenses: custom
Conflicts: env-modules, lmod-git
Provides: env-modules
Submitter: wookietreiber
Maintainer: matse
Last Packager: matse
Votes: 7
Popularity: 0.61
First Submitted: 2017-01-17 13:22
Last Updated: 2021-09-24 18:54

Required by (7)

Sources (1)

Latest Comments

1 2 3 Next › Last »

matse commented on 2021-04-12 13:36

@sogaiu: thanks for the hint! That were indeed the wrong filenames. I've updated the hint with the correct filenames.

sogaiu commented on 2021-04-12 13:22

The current install message has the text (in lmod.install):

----------------------------------------------------
In order tu use lmod make sure to source
/etc/profile.d/module.sh or /etc/profile.d/module.csh
----------------------------------------------------

May be it's a bit better if modules.sh and modules.csh were used in that text instead of module.sh and module.csh respectively.

matse commented on 2020-09-04 17:23

@berquist: Updated to newest release and done. Thanks for the hint.

berquist commented on 2020-09-04 02:43

Can you change env-modules-tcl to env-modules inprovides and conflicts?

matse commented on 2020-08-06 10:28

@simonp yes, it's because of the update to lua 5.4 and broken lua-posix at the moment. Since the package was updated today, just reinstall / recompile lua-posix and it will work again.

lahwaacz commented on 2020-08-06 10:14

@simonp: you need to rebuild all lua modules and this package for the new lua version.

simonp commented on 2020-08-06 09:32

I'm getting the following error after updating lua this morning:

/usr/bin/lua: version mismatch: app. needs 503.0, Lua core provides 504.0 stack traceback: [C]: in ? [C]: in function 'require' /usr/share/lua/5.3/posix/init.lua:23: in main chunk [C]: in function 'require' /usr/share/lmod/lmod/libexec/lmod:61: in main chunk [C]: in ?

matse commented on 2019-06-19 23:23

lahwaacz: Convinced and thanks for the information! Fixed!

lahwaacz commented on 2019-06-19 05:34

matse: The assumption is for the base-devel group, not for base - see e.g. https://bbs.archlinux.org/viewtopic.php?pid=1699678#p1699678. The wiki was wrong, I just fixed that.

matse commented on 2019-06-18 23:11

lahwaacz: procps-ng belongs to the base group, which is assumed to be installed on systems, on which you build your own packages, see: https://wiki.archlinux.org/index.php/Makepkg#Usage