Package Details: llvm-amdgpu 3.5.1-1

Git Clone URL: https://aur.archlinux.org/llvm-amdgpu.git (read-only, click to copy)
Package Base: llvm-amdgpu
Description: Radeon Open Compute - LLVM toolchain (llvm, clang, lld)
Upstream URL: https://github.com/RadeonOpenCompute/llvm-project
Licenses: custom:Apache 2.0 with LLVM Exception
Submitter: acxz
Maintainer: rsa (acxz)
Last Packager: rsa
Votes: 2
Popularity: 0.68
First Submitted: 2020-04-25 23:50
Last Updated: 2020-06-20 20:03

Pinned Comments

acxz commented on 2020-03-09 06:41

Development is on Github: https://github.com/rocm-arch/rocm-arch Please open issues and PRs there instead of commenting.

Latest Comments

rsa commented on 2020-06-21 19:08

@rigred https://github.com/RadeonOpenCompute/llvm-project/releases/tag/rocm-3.5.1

rigred commented on 2020-06-21 12:42

How is this already at 3.5.1 when the github tree is still at 3.5.0?

kode54 commented on 2020-06-09 07:23

Anybody else finding that this thing, with GCC 10 installed, requires way too damn much memory to compile? I'm running out of memory with 16GB of RAM and an 8GB swap partition. I am trying again with LTO disabled in my makepkg.conf.

rsa commented on 2020-04-05 14:39

@petronny it should be fixed now

petronny commented on 2020-03-22 04:10

-- Performing Test CXX_SUPPORTS_FDATA_SECTIONS - Success
-- Looking for os_signpost_interval_begin
-- Looking for os_signpost_interval_begin - not found
-- Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) 
CMake Error at CMakeLists.txt:658 (message):
  Unable to find Python interpreter, required for builds and testing.



  Please install Python or specify the PYTHON_EXECUTABLE CMake variable.


-- Configuring incomplete, errors occurred!
See also "/build/llvm-roc/src/CMakeFiles/CMakeOutput.log".
See also "/build/llvm-roc/src/CMakeFiles/CMakeError.log".

Please add missing dependency.

acxz commented on 2020-03-09 06:41

Development is on Github: https://github.com/rocm-arch/rocm-arch Please open issues and PRs there instead of commenting.

dluciv commented on 2020-02-01 20:13

https://github.com/RadeonOpenCompute/llvm-project/archive/roc-ocl-3.0.0.tar.gz matches the checksum

naetherm commented on 2020-01-31 05:57

Seems your download path for the package is wrong. Did you mean "roc-ocl-$_srcver.tar.gz" or the "roc-hcc-$_srcver*"? Btw, thanks for the work on this, I wanted to do exact the same but did not find the time for it ...

KozRoss commented on 2020-01-30 20:08

The link https://github.com/RadeonOpenCompute/llvm-project/archive/llvm-roc-ocl-3.0.0.tar.gz 404s for me.