Package Details: litecli 1.6.0-1

Git Clone URL: https://aur.archlinux.org/litecli.git (read-only, click to copy)
Package Base: litecli
Description: A command-line client for SQLite databases that has auto-completion and syntax highlighting.
Upstream URL: https://github.com/dbcli/litecli
Keywords: litecli sql sqlite
Licenses: BSD
Conflicts: litecli-git
Provides: litecli
Submitter: andrejr
Maintainer: andrejr
Last Packager: andrejr
Votes: 3
Popularity: 0.126223
First Submitted: 2018-12-20 10:29
Last Updated: 2021-04-09 11:14

Latest Comments

andrejr commented on 2021-01-02 18:01

Updated, sorry for the delay.

txtsd commented on 2021-01-01 04:45

Thanks. If @andrejr can't update this themselves, they needs to add maintainers.

snowball commented on 2020-12-31 21:25

@txtsd: There was a new release earlier this month that includes the fix for the sqlparse issue:

diff --git a/PKGBUILD b/PKGBUILD
index 69467ec..39c1354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4 +4 @@ pkgname=litecli
-pkgver=1.3.2
+pkgver=1.5.0
@@ -26 +26 @@ conflicts=('litecli-git')
-md5sums=('dd19a67302b6108fdb17c3af5bbdac9b')
+md5sums=('0ff999a63dc9d0d44efe3c1e3ac96a85')

txtsd commented on 2020-12-27 12:19

@andrejr Can you apply the fix submitted below?

snowball commented on 2020-10-31 04:57

python-sqlparse 0.4.x was released earlier this month, which broke litecli:

$ litecli test.db
...
ModuleNotFoundError: No module named 'sqlparse.compat'

Here's an updated PKGBUILD that applies the fix from upstream master:

# Maintainer: Andrej Radović <r.andrej@gmail.com>

pkgname=litecli
pkgver=1.3.2
pkgrel=2
pkgdesc="A command-line client for SQLite databases that has auto-completion "\
"and syntax highlighting."
url="https://github.com/dbcli/litecli"
arch=(any)
license=('BSD')
depends=(
  'python'
  'python-click'
  'python-pygments'
  'python-prompt_toolkit'
  'python-sqlparse'
  'python-configobj'
  'python-cli_helpers'
)
makedepends=('python-distribute')
source=(
  $pkgname-$pkgver.zip::https://github.com/dbcli/litecli/archive/v$pkgver.zip
  https://github.com/dbcli/litecli/commit/37957e401d22f88800bbdec2c690e731f2cc13bd.diff
)
provides=('litecli')
conflicts=('litecli-git')
md5sums=('dd19a67302b6108fdb17c3af5bbdac9b'
         'fe4fdbd8b712c71b8ac5dc9403f8a384')

prepare() {
  cd "$srcdir/${pkgname}-${pkgver}"

  # Fix compatibility with sqlparse >= 0.4.0
  # https://github.com/dbcli/litecli/pull/102
  patch -N -p1 -i "$srcdir/37957e401d22f88800bbdec2c690e731f2cc13bd.diff"
}

package() {
  cd "$srcdir/${pkgname}-${pkgver}"
  sed -i "s/cli_helpers\[styles\] >= 1.0.1/cli_helpers >= 1.1.0/g" \
    setup.py
  python setup.py install --root="$pkgdir/" --optimize=1
  install -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}

gardar commented on 2020-01-24 19:32

Current version of python-prompt_toolkit in the repo is too new https://www.archlinux.org/packages/community/any/python-prompt_toolkit/

andrejr commented on 2019-11-17 14:28

You may use this version of sqlparse with litecli, pgcli, mycli, because the one in the repos is too new:

https://aur.archlinux.org/packages/python-sqlparse-cli_helpers/

shastry commented on 2019-08-14 03:55

litecli command fails: pkg_resources.DistributionNotFound: The 'sqlparse<0.3.0,>=0.2.2' distribution was not found and is required by litecli

Upstream needs to update, but can be temporarily overridden in PKGBUILD with:

sed -i "s/sqlparse>=0.2.2,<0.3.0/sqlparse>=0.2.2,<0.4.0/g" setup.py