Package Details: linux-xanmod-git 5.11.2.xanmod1.r0.g39be9f695492-1

Git Clone URL: https://aur.archlinux.org/linux-xanmod-git.git (read-only, click to copy)
Package Base: linux-xanmod-git
Description: The Linux kernel and modules with Xanmod patches
Upstream URL: http://www.xanmod.org/
Keywords: kernel xanmod
Licenses: GPL2
Submitter: figuepluto
Maintainer: figue (figuepluto, jfigueras)
Last Packager: figue
Votes: 1
Popularity: 0.000186
First Submitted: 2017-03-23 12:11
Last Updated: 2021-04-03 23:51

Latest Comments

FuelFlo commented on 2021-01-29 00:44

@figue thanks for the heads up! Strange though, that there is a gap and just Kaby Lake is missing.

figue commented on 2021-01-28 20:31

@FuelFlo Now I see that Kaby Lake is not in Xanmod code... You can always use native optimization (now the number is 99) and gcc will choose the best in your case.

Anyway, I think you can use Skylake and it will be fine.

figue commented on 2021-01-28 19:59

@FuelFlo you are right. I need to update my script. Give me some time and I will add. See this commit for reference:

https://github.com/xanmod/linux/commit/2f8656f5c0c21b59b871ef486ea306865f870d9e

FuelFlo commented on 2021-01-28 17:22

Does anyone know why there is no option for Intel 7th Gen. (Kaby Lake) CPU optimization available in choose-gcc-optimization.sh?

And which one should I choose instead, if I have a Kaby Laky CPU and want some optimizations?

figue commented on 2020-12-10 16:45

Thanks! ec1aae4b4d0f

Scimmia commented on 2020-12-10 16:39

Please see the warning here: https://wiki.archlinux.org/index.php/Kernel/Arch_Build_System#Modifying_the_PKGBUILD

figue commented on 2020-11-25 17:04

@nicman23 cachy is in a separate git branch now:

https://github.com/xanmod/linux/tree/5.9-cachy

You can edit my PKGBUILD and pull from there... Probably changing:

_branch=5.9 to _branch=5.9-cachy will work (I didn't tested).

Or you can use linux-xanmod package which download from the cachy branch or stock branch according to user choice.

nicman23 commented on 2020-11-25 16:46

hey i cannot seem to enable cachy after compiling with it

figue commented on 2020-11-20 21:46

@nicman23 done. Thanks!

nicman23 commented on 2020-11-20 15:31

please remove deps python-sphinx python-sphinx_rtd_theme graphviz imagemagick as they are not relevant - they are for building docs