Package Details: linux-steam-integration 0.7.3-2

Git Clone URL: https://aur.archlinux.org/linux-steam-integration.git (read-only, click to copy)
Package Base: linux-steam-integration
Description: Helper for enabling better Steam integration on Linux
Upstream URL: https://github.com/clearlinux/linux-steam-integration
Keywords: linux-steam-integration solus steam
Licenses: LGPL2.1
Submitter: z3ntu
Maintainer: z3ntu
Last Packager: z3ntu
Votes: 24
Popularity: 0.006212
First Submitted: 2016-07-19 12:53
Last Updated: 2020-03-29 15:51

Pinned Comments

z3ntu commented on 2017-10-12 16:14

If you are having problems installing this package due to signature verification, please run the below before running makepkg:

gpg --recv-keys 8876CC8EDAEC52CEAB7742E778E2387015C1205F

Latest Comments

1 2 Next › Last »

snostorm commented on 2020-03-25 22:25

can we get the diff kode54 has below integrated as patch until it is fixed in the master branch. I tested it and it works fine.

thaewrapt commented on 2020-02-02 19:49

@kode54 actually, I've found a fork with this particular change already: https://github.com/BlackholeEscaper/linux-steam-integration

Dunno, why it hasn't got a pull-request into the mainline for that long, or if it's even working (haven't checked yet).

kode54 commented on 2020-01-28 09:18

Easy enough to fix upstream, or fix in this repository, in case it's not applicable to upstream:

diff -urN linux-steam-integration-0.7.3-orig/src/intercept/main.c linux-steam-integration-0.7.3/src/intercept/main.c
--- linux-steam-integration-0.7.3-orig/src/intercept/main.c 2020-01-28 01:17:13.983437325 -0800
+++ linux-steam-integration-0.7.3/src/intercept/main.c  2020-01-28 01:17:32.551437453 -0800
@@ -323,7 +323,7 @@
         "libcurl-gnutls.so.4",
         "libcurl.so.4",

-        "libbz2.so.1.0.6",
+        "libbz2.so.1.0.8",

         "libudev.so.1",
 };

Best also check this in case there are any other intercepts that point at obsolete SONAMEs.

ozmartian commented on 2019-10-10 02:24

this is a hack to get it working until things are fixed upstream. just create symbolic links to the latest bz2 lib in BOTH x64 and x32 lib folders. make a note of this so you can clean it up when this is properly fixed.

$ sudo ln -s /usr/lib/libbz2.so.1.0.8 /usr/lib/libbz2.so.1.0.6

$ sudo ln -s /usr/lib32/libbz2.so.1.0.8 /usr/lib32/libbz2.so.1.0.6

pedrogabriel commented on 2019-08-04 01:44

I have steam-native-runtime installed and it has lib32-bzip2 as a dependency so it's not lacking the library. But the soname is different, the arch version is 1.0.8 while the lsi-steam was expecting 1.0.6. The reak problem there is that the steam-native-runtime starts normally and don't asks for this specific version while lsi-steam fails to startup.

ax34 commented on 2019-08-03 21:12

Maybe this package needs lib32-bzip2 as a dependency?

pedrogabriel commented on 2019-08-03 13:52

Starting steam with native libraries using this brings me this error:

Running Steam on arch rolling 64-bit
STEAM_RUNTIME is disabled by the user
Error: You are missing the following 32-bit libraries, and Steam may not run:
libbz2.so.1.0.6
libbz2.so.1.0.6
Error:
You are missing the following 32-bit libraries, and Steam may not run:
libbz2.so.1.0.6
libbz2.so.1.0.6

which does not occur using the steam-native provided by the steam package.

yochananmarqos commented on 2019-01-01 18:24

The continuation of the project by Clear Linux is here: https://github.com/clearlinux/linux-steam-integration

ILMostro7 commented on 2018-07-13 18:29

The PGP key listed has expired.

gpg: data source: https://37.191.226.104:443
(1)     Ikey Doherty (Solus Project Founder) <ikey@solus-project.com>
          4096 bit RSA key 78E2387015C1205F, created: 2016-02-22, expires: 2018-02-21 (expired)

Sandro8086 commented on 2017-12-30 14:31

Hi, I'm having troubles getting the GPG key, this is the error I get

gpg: keyserver receive failed: Server indicated a failure

edit: nevermind, after five attempts it worked.