Package Details: linux-show-player 0.5.1_py3.7-1

Git Clone URL: https://aur.archlinux.org/linux-show-player.git (read-only)
Package Base: linux-show-player
Description: Sound cue playback software designed for live musical shows and theatre plays
Upstream URL: http://linux-show-player.sourceforge.net/
Keywords: cue musical player show theatre
Licenses: GPL3
Submitter: AsA
Maintainer: AsA (SpotlightKid)
Last Packager: SpotlightKid
Votes: 6
Popularity: 0.039286
First Submitted: 2015-08-09 19:44
Last Updated: 2018-08-08 10:08

Dependencies (10)

Required by (0)

Sources (1)

Latest Comments

SpotlightKid commented on 2019-05-13 16:58

@archmylinux: there you go: https://aur.archlinux.org/packages/linux-show-player-git

archmylinux commented on 2019-05-13 15:05

Well, I should have written "not fluid enough" as "not trying at all" all I had to do was change source and md5sums to :

source=("git+file:///a/b/c/linux-show-player#branch=develop") md5sums=('SKIP')

And remove all :

-${pkgver/_/-}"

instances.

Wow ! Lots of new stuff in develop ! The only thing keeping me from ditching CueLab was midi and osc control of e.g. the main "GO" button which is now implemented !!! :-D

archmylinux commented on 2019-05-13 14:43

Thanks for this package !

Are there plans to make a -git version of this package?

I'm not fluid enough to make an Arch package on my own or to modify this package to take a git repository as a source rather than a fixed file. I would love to compile from the devel branch.

What I usually do for other *-git package-build is to point to whatever branch of my local clone of the source repository.

SpotlightKid commented on 2017-04-07 17:39

@ceppo93: thanks for the heads up! This is now fixed.

ceppo93 commented on 2017-04-07 09:16

It depends also on "qt5-svg" (optional for python3-pyqt5), otherwise svg icons are not rendered.

Yinameah commented on 2017-03-07 00:26

Hello,
A new release of linux-show-player is now available. I updated the PKGBUILD at this address if you want to use it here to provide last version : https://gist.github.com/Yinameah/7797fbe8451afb63d67eb57c4b3ee7b3
It worked well for me but I'm no expert with AUR builds so I let you check

AsA commented on 2016-05-25 20:31

Thank you Christopher for the comment. I see that you are much more experienced than me in package maintainance. Would you consider to became full or co-maintainer of this package?

SpotlightKid commented on 2016-05-25 16:21

New version 0.4 adds a new dependency on package python-sortedcontainers.

License should be 'GPL3', not 'GPLv3'.

Architecture should be 'any', shouldn't it? Only Python code, no binaries in the package.

Here's an updated PKGBUILD:

https://gist.github.com/c50d942581092494d71ad75e8a849c35