Package Details: linux-rt 5.4.13.7-1

Git Clone URL: https://aur.archlinux.org/linux-rt.git (read-only, click to copy)
Package Base: linux-rt
Description: The Linux-rt kernel and modules
Upstream URL: https://wiki.linuxfoundation.org/realtime/start
Licenses: GPL2
Submitter: schivmeister
Maintainer: jhernberg (dvzrv)
Last Packager: dvzrv
Votes: 165
Popularity: 1.16
First Submitted: 2011-08-09 20:03
Last Updated: 2020-01-21 11:01

Required by (10)

Sources (20)

Pinned Comments

dvzrv commented on 2019-05-13 21:17

I have added a signed, unofficial user repository for linux-rt, backed by this PKGBUILD.

You can add it to your pacman.conf with:

[dvzrv]
Server = https://pkgbuild.com/~dvzrv/repo/$arch

I'll try to keep it as up-to-date as possible and retain old versions.

Enjoy!

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Alvo commented on 2020-01-03 22:37

I can't get it to work even with nvidia-dkms as the only dkms. I'm going to ask this question on the linux-rt-users.

aquilarubra commented on 2020-01-03 06:04

I also had issues with nvidia-dkms, with a previous kernel. Then, I don't know how they disappeared. It might be the latest kernel. Or it might be that I replaced it with nvidia, upgraded the kernel, then replaced nvidia with nvidia-dkms again just to test once more, and it was working. Check also if you have other dkms modules, which might interfere and hide the real problem.

Alvo commented on 2020-01-03 03:57

@dvzrv Thanks for the info I was able to boot into linux-rt without problem! I still get error when I run startx to start my window manager. The error I saw in demsg was "NVRM: failed to copy vbios to memory". I'm using nvidia-dkms and it's working fine with linux-ck-ivybridge. I wonder if you have experienced such issue before. Thanks in advance!

aquilarubra commented on 2019-12-30 21:59

Tried, but same result. Core dump, and disks not recognized. I will live with virtualbox only in a linux kernel. It's a pity, because I was running VST plugins in Windows, routed to Linux. I don't plan to change virtualbox, as I carry an external disk with the virtualbox images wherever I go. I see that there are many issues with virtualbox, so perhaps they will be fixed somewhen. But at the moment, linux-rt is the only kernel having these issues.

dvzrv commented on 2019-12-30 16:53

Also, sorry, I forgot to push the changes for 5.4.5.3 ;-) It is up now. Enjoy.

dvzrv commented on 2019-12-30 16:50

@aquilarubra: I don't use virtualbox, sorry. There seems to be an issue with it on current vanilla kernel as well (and this is not the first time DKMS for it breaks). If you can switch, I would suggest looking into KVM/QEMU to have less of a pain with the out-of-tree modules.

In regards to the topic of older kernels, they are all still there: https://pkgbuild.com/~dvzrv/repo/x86_64/

Note, that due to the way mkinitcpio and all kernel packages were changed, you might have to remove vmlinuz images in /boot before downgrading (depending on how far back you go).

dvzrv commented on 2019-12-30 16:44

@Alvo: Please make sure to read the news on the main website. There was an item about this.

Alvo commented on 2019-12-30 03:28

Hello, I have trouble generating vmlinuz for this kernel. There was no vmlinuz generated after installation and there is no preset for this kerenl while running mkinitcpio. Can someone help me with this problem?

aquilarubra commented on 2019-12-29 20:58

Thanks for answers. I didn't have the time to try again, but I will give it a shot again. It was a pain to go back to AMD, after so many years. I experienced issues of any kind, but now that I solved each of them one by one, the result is impressive - compared to Intel, where I wasn't able to solve everything. Being my machine new, I don't have the older kernels. I'm not sure how to get them. But it's just fine to experiment with the 5.4.3 kernel. You mentioned 5.4.5... any new update?

Ralf_Mardorf commented on 2019-12-26 14:00

Hi aquilarubra, I just want to let you know that virtualbox seems not to work on an Intel machine, when booted into "my" 5.4.5_rt3, but it works when booted into 5.4.6.arch3-1. Sorry, there's no time for further investigations. Regards, Ralf